Results 1 to 3 of 3
  1. #1
    New Member
    Join Date
    Jun 2012
    Posts
    2
    Location
    Leon, TX
    Tractor
    Ford 1910

    Default Ford 1910 PTO Issue

    I have a Ford 1910 tractor which the PTO disengages when trying to shred. I was curious why this may be occuring? Should I add hydraulic fluid? the PTO operated fine but after shredding for a while it began disengaging.
    The tractor belongs to my father so I do not have much knowledge about it. If someone could maybe help with a some information that would be a huge help.

  2. #2
    Super Star Member RoyJackson's Avatar
    Join Date
    Nov 2001
    Posts
    18,044
    Location
    Bethel, Vermont
    Tractor
    John Deere 4400 MFWD, Deere 855D UTV and assorted implements

    Default Re: Ford 1910 PTO Issue

    Is the rotary cutter (shredder) the only PTO driven implement that causes problems?
    Does the cutter run for a while before it disengages?
    Before any disassembly, start troubleshooting the linkages. I don't know if the PTO is hydraulically driven, but it can't hurt to ensure the hydraulic fluid is at the correct level.

    You may have better responses posting this in the New Holland forum or the general Owning/Operating or Parts and Repairs forum...please select one...don't double post (that causes confusion)
    Roy Jackson

    "Any government that does not trust its citizens with firearms is either a tyranny, or planning to become one."
    -Joseph P. Martino

  3. #3
    Epic Contributor Soundguy's Avatar
    Join Date
    Mar 2002
    Posts
    46,360
    Location
    Central florida
    Tractor
    ym1700, NH7610S, Ford 8N, 2N, NAA, 660, 850 x2, 541, 950, 951, 2000, 3000, 4000, 4600, 5000, 740, IH 'C' 'H', CUB, John Deere 'B', allis 'G', case VAC

    Default Re: Ford 1910 PTO Issue

    check for in / out play on the pto stub shaft..

    post back

Similar Threads

  1. L2800-L3400 PTO Making the right choice
    By 8226hamer in forum Kubota Owning/Operating
    Replies: 281
    Last Post: 03-17-2014, 08:16 AM
  2. Ford 601 Workmaster PTO Problem
    By swampdog in forum Parts/Repairs
    Replies: 17
    Last Post: 05-25-2012, 04:56 PM
  3. Ford 1710 PTO ??
    By dboacres in forum Owning/Operating
    Replies: 2
    Last Post: 02-23-2010, 06:45 PM
  4. Rear PTO on Ford 4400 industrial tractor?
    By kvancott in forum Customization
    Replies: 4
    Last Post: 12-02-2009, 02:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2013 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.