Results 1 to 5 of 5
  1. #1

    Default Another RTV 1100 Turbo

    Following Mikeyd lead I installed a TD03-7G turbo on my new RTV1100.

    After getting everything fabricated and bolted on i fired it up and to my surprise is was not getting any boost. The turbo is brand new and I checked the waste gate to make sure it was not stuck open for some reason.

    I have a 2 1/2 inch exhaust so there shouldn't be any back pressure problems.

    Any one have any ideas why this turbo is not pumping air????

    Thanks,
    Chuck

  2. #2
    Platinum Member firefighter9208's Avatar
    Join Date
    Dec 2006
    Posts
    826
    Location
    Springville, Alabama
    Tractor
    2004 Kubota M4800

    Default Re: Another RTV 1100 Turbo

    Was the engine under load? A turbo won't build boost at idle. On my F250 Powerstoke I can run at 55 mph steady throttle on flat ground and the boost guage will read 0. If I start up a grade or roll in the throttle the boost will come up. If I step on it hard it will hit 22-25 psi.

    Chris
    2004 Kubota M4800 with Bushhog M346 Loader with 6' Heavy Duty Bucket and Bale Spear. 6' Bushhog SQ720 Mower, Bushhog RDTH72 Finish Mower. Bushhog 3pth Log Splitter. Andy Tatro Grapple. Home Made 48" pallet forks.

    1966 Farmall 140 with cultivators and fertilizer attachment.

    1999 F250 LWB Ext. Cab 7.3L Powerstroke, ZF 6 Speed, Chip, Exhaust, Cool Air Intake.

    2009 Chevrolet Traverse

    1969 Mach1 Mustang 351W. Too much to list.

  3. #3

    Default Re: Another RTV 1100 Turbo

    Quote Originally Posted by firefighter9208
    Was the engine under load? A turbo won't build boost at idle. On my F250 Powerstoke I can run at 55 mph steady throttle on flat ground and the boost guage will read 0. If I start up a grade or roll in the throttle the boost will come up. If I step on it hard it will hit 22-25 psi.

    Chris
    yes it was under load. I did find a leak in on one of the flanges on the exhaust and now i'm getting 3 psi boost. still too low.

    Any one have any ideas why i'm not getting the right boost.

    REgards, Chuck

  4. #4
    Platinum Member firefighter9208's Avatar
    Join Date
    Dec 2006
    Posts
    826
    Location
    Springville, Alabama
    Tractor
    2004 Kubota M4800

    Default Re: Another RTV 1100 Turbo

    Gotcha,

    When I put a boost guage on my truck I got in and revved it up and nothing. I thought, "I know this thing is making boost". Then I took it down the road. Guess it was just me.

    Chris
    2004 Kubota M4800 with Bushhog M346 Loader with 6' Heavy Duty Bucket and Bale Spear. 6' Bushhog SQ720 Mower, Bushhog RDTH72 Finish Mower. Bushhog 3pth Log Splitter. Andy Tatro Grapple. Home Made 48" pallet forks.

    1966 Farmall 140 with cultivators and fertilizer attachment.

    1999 F250 LWB Ext. Cab 7.3L Powerstroke, ZF 6 Speed, Chip, Exhaust, Cool Air Intake.

    2009 Chevrolet Traverse

    1969 Mach1 Mustang 351W. Too much to list.

  5. #5
    New Member
    Join Date
    Dec 2007
    Posts
    6
    Location
    Bayfield CO

    Default Re: Another RTV 1100 Turbo

    Check out the last Dyno on the RTV1100, Stock vs Turbo.
    Also, The emissions was reduced from 18.2% Peak Opacity down to an amazing 11.2%

    You can see it on our site rtvturbo.com

    Or Direct:
    kubota RTV1100 Turbo -Vs- Stock - 12-02-10 With Smoothing

    Travis Imel
    travis@swaginc.com
    swaginc.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.