Results 1 to 3 of 3
  1. #1
    New Member
    Join Date
    Jun 2009
    Posts
    1
    Location
    Fredericktown, Missouri
    Tractor
    Branson 3510

    Default Polaris electric start problem

    I have a Polaris 325 Expedition (2000). The electric start will only work in neutral when the green light comes on. Lately the light doesn't come on and I have to pull start the machine. Any help?

    Thanks

  2. #2
    Super Member timswi's Avatar
    Join Date
    Nov 2008
    Posts
    5,007
    Location
    Beaver County Pa
    Tractor
    Kubota BX23 & RTV1100

    Default Re: Polaris electric start problem

    Quote Originally Posted by hot pepper View Post
    I have a Polaris 325 Expedition (2000). The electric start will only work in neutral when the green light comes on. Lately the light doesn't come on and I have to pull start the machine. Any help?

    Thanks
    Had that problem with a yamaha big bear, had to rock the machine back and forth in neutral or in gear a few times to get the safety switch to activate...Just a suggestion.
    BX23TLB & RTV1100 with 72" Power Angle Plow

  3. #3
    New Member
    Join Date
    Jul 2009
    Posts
    3
    Location
    central, mo.
    Tractor
    06 polaris ranger 4x4

    Default Re: Polaris electric start problem

    Had a simular problem. Mice had chewed some wires.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.