Results 1 to 3 of 3
  1. #1
    New Member JHK Farms's Avatar
    Join Date
    Apr 2009
    Posts
    17
    Location
    Maud, OK
    Tractor
    Several, newest Bransons 4820

    Default 2003 Polaris 330 Magnum 2X4

    My son's 2003 Polaris 330 magnum's battery was weak, but you could still pull start it. Then all of a sudden, it would pull start, then quit running after a few minutes. Now it will not start. I pulled the spark plug, it did not have any spark. When I removed the battery, it was completely dry. My question is, do you have to have a working battery for the Polaris to run? Or do I have other problems?
    Thanks
    JHK Farms

  2. #2
    Gold Member shot_gun's Avatar
    Join Date
    Mar 2008
    Posts
    386
    Location
    NJ

    Default Re: 2003 Polaris 330 Magnum 2X4

    If your charging system is not working ...maybe. You may be able to hook jumper cables to it from your car/truck to see if it starts or has spark. that will be one way to tell.
    S_G

    Remember nobody ever complained about having too much horsepower!

  3. #3
    Member
    Join Date
    Mar 2007
    Posts
    33

    Default Re: 2003 Polaris 330 Magnum 2X4

    I installed a new battery, the 4-wheeler fired right up. The kids forgot to tell me that when they turned on the lights, it would die.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2013 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.