Results 1 to 4 of 4
  1. #1
    Member
    Join Date
    Feb 2005
    Posts
    26

    Default RTV 900 Transmission Oil Drain Plug

    Just curious to see if anyone else has had problems. Bought a used 2004 model this year. Asked previous owner if the Tranny had its scheduled service-no. Today I decided to change the fluid and filters. The plug was extremely hard to remove. When I was cleaning the metal shavings off the plug I noticed that the threats had something in them also. Picked metal off them. When I tried to re-install plug it would not even snug as it was completely striped out. This is a first for me in over 40 yrs., of doing all of my maintenance on everything from lawnmowers to a 40' Diesel Pusher MH.
    I just wonder if there has been any issues with this in the past.
    Other then this, I really like the Bota so far. Thanks for any suggestions,answers.

  2. #2
    Veteran Member
    Join Date
    Jul 2004
    Posts
    2,315

    Default Re: RTV 900 Transmission Oil Drain Plug

    Kraut,

    I have not heard of this issue.
    Was it cross-threaded when installed? If the threads are stripped, is there any similar damage to the threads in the tranny housing?

    Brian

  3. #3
    Member
    Join Date
    Feb 2005
    Posts
    26

    Default Re: RTV 900 Transmission Oil Drain Plug

    The plug seems to be alright. The metal shaving came from the threads in the tranny housing.

  4. #4
    Veteran Member
    Join Date
    Jul 2004
    Posts
    2,315

    Default Re: RTV 900 Transmission Oil Drain Plug

    Is everything OK now?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2013 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.