Page 2 of 5 FirstFirst 12345 LastLast
Results 11 to 20 of 48
  1. #11
    Silver Member SABULA FARMER's Avatar
    Join Date
    Feb 2007
    Posts
    225
    Location
    Pennsylvania
    Tractor
    Bobcat CT335SST

    Default Re: Tach/Electrical Issue

    Ok same issue here with my CT335....I have no Tach, or idiot lights. If I turn the ignition switch several times they will come on....WTH?
    I am calling the dealer tomorrow.
    S.F.
    ...I have all the answers, can you wait a minute while I ask my wife?

    2010 Bobcat CT335, 5' King Kutter Hog, 5' Bush Hog Finish Mower, 14" 2 Bottom Plow, 6' V Discs, 8' Chain Link Harrow, 7' Bush Hog Back Blade

  2. #12
    Bronze Member
    Join Date
    Aug 2010
    Posts
    53
    Location
    Whitesburg, KY
    Tractor
    2010 Bobcat CT335ss

    Default Re: Tach/Electrical Issue

    Quote Originally Posted by SABULA FARMER View Post
    Ok same issue here with my CT335....I have no Tach, or idiot lights. If I turn the ignition switch several times they will come on....WTH?
    I am calling the dealer tomorrow.
    S.F.
    Let us know what you find out!

  3. #13
    Bronze Member
    Join Date
    Aug 2010
    Posts
    53
    Location
    Whitesburg, KY
    Tractor
    2010 Bobcat CT335ss

    Default Re: Tach/Electrical Issue

    Spent most of the day checking the ground and positive cables, no issues found.

    The ONLY power I get to the dash is turning the key backwards and I get the glow plug light, with key off I can turn flashers on and hear the flasher buzzing-clicking but the lights do not lite up.

    Occasionally I can move the key to the on position and hear the relays licking, but that rarely happens.

    I do get good voltage to the key switch.

  4. #14
    Veteran Member milkman636's Avatar
    Join Date
    Aug 2010
    Posts
    1,176
    Location
    Palm of the Right Hand
    Tractor
    Bobcat CT335 + Kubota BX2370-1

    Default Re: Tach/Electrical Issue

    I had trouble with my tach and gauges not working a couple times last fall. I ended up having to pull the ground cable from the battery off the tractor frame and cleaning that connection real well. It was corroded and pitting slightly. I polished the frame and the ring terminal then put some battery post terminal spray over the reassembled connection to keep it clean. It has worked fine since. I know that you stated you had voltage at the key switch, but have you pulled the bolt that connects the battery ground cable to the tractors frame to physically check that connection? It has been a consistent trouble spot that has caused instrument problems on these machines.
    "Contentment makes poor men rich, Discontent makes rich men poor." Benjamin Franklin

    "...The conflict between believers and non believers is not about the beliefs..." IslandTractor

  5. #15
    Silver Member SABULA FARMER's Avatar
    Join Date
    Feb 2007
    Posts
    225
    Location
    Pennsylvania
    Tractor
    Bobcat CT335SST

    Default

    Talked to the dealer yesterday.... I have a new ignition switch coming. After explaining about the electrical issues, we thought it was the main computer. If you wiggle the last plug under the hood closest to the main computer, the tractor will try and start! Short somewhere!
    The entire dash panel has been going nuts!! Turn on the 4wd, tach works, hit the brakes, the hour meter works but the tach will stop. It's crazy!
    I sure hope it's the ignition switch like they think it is or I'm up a ***** creek in a chicken wire canoe.
    S.F.
    ...I have all the answers, can you wait a minute while I ask my wife?

    2010 Bobcat CT335, 5' King Kutter Hog, 5' Bush Hog Finish Mower, 14" 2 Bottom Plow, 6' V Discs, 8' Chain Link Harrow, 7' Bush Hog Back Blade

  6. #16
    New Member
    Join Date
    Sep 2013
    Posts
    4
    Location
    MIchigan
    Tractor
    Bobcat CT230

    Default Re: Tach/Electrical Issue

    Did the switch fix your issue?

  7. #17
    New Member
    Join Date
    Oct 2013
    Posts
    9
    Location
    Vancouver
    Tractor
    Bobcat

    Default Re: Tach/Electrical Issue

    I am having the same dash issues. My ct235 has no lights, hour meter,tachometer or temp guage. The tach comes on sometimes but as soon as I turn on the lights all the dash dies. Any answers?

  8. #18
    Gold Member
    Join Date
    Jul 2007
    Posts
    446
    Location
    Pennsylvania
    Tractor
    Bobcat

    Default Re: Tach/Electrical Issue

    So did anyone ever get their tractors fixed?

  9. #19
    New Member
    Join Date
    Oct 2013
    Posts
    9
    Location
    Vancouver
    Tractor
    Bobcat

    Default Re: Tach/Electrical Issue

    No. I called the dealer and he had no ideas other than to bring the machine to him. That involves a ferry ride, 1.5 hr drive and great expense. I have checked and replaced the battery terminals, checked cleaned and re attached the ground and no difference. The tach will come alive for short periods but when the lights are tried it dies immediately. With winter coming this is a real pain, especially with a tractor with less than 150 hours on it. Any ideas, or has anybody with the same issues found a fix.

  10. #20
    Gold Member
    Join Date
    Jul 2007
    Posts
    446
    Location
    Pennsylvania
    Tractor
    Bobcat

    Default Re: Tach/Electrical Issue

    I fixed mine this morning, found that the starter relay was bad. So far so good been using it most of the day with no issues. My relay was under the hood kind of on the firewall but mine is a CT450. When I grabbed the relay mine dash would come in and out, so I swapped it out with new one and its been good.

Page 2 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. Loader B2320 Loader Issue?
    By maximus1277 in forum Kubota Owning/Operating
    Replies: 29
    Last Post: 09-04-2011, 12:36 AM
  2. Bolens 1468 G14XL steering issue
    By NewtoBolens37 in forum Projects
    Replies: 1
    Last Post: 05-13-2011, 06:53 PM
  3. new craftsman GT6000 Kohler eng issue
    By SPIKER in forum Craftsman / Sears
    Replies: 3
    Last Post: 05-10-2011, 09:09 PM
  4. T2310 Starting Issue
    By jonnykk in forum New Holland Owning/Operating
    Replies: 16
    Last Post: 11-25-2010, 11:06 AM
  5. Flail Mower Flail Mower Issue
    By Mike5252 in forum Attachments
    Replies: 7
    Last Post: 05-14-2008, 09:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.