This is not the typical stuck clutch from sitting too long.

I was operating the tractor moving dirt with the FEL. Everything had been going just fine, no issues for about 45 minutes of work. Then after getting another scoop from the pile I pressed in the clutch and it did not disengage. I had to forcefully push the gear lever out of gear, into neutral.

I got the tractor going again by letting it roll and slipping it into gear. I tried depressing the clutch and pressing the brakes, extremely hard. On the fifth try I got it to stop. Tried a few gears and I thought it was working. Then it jammed again. I tried several more times to break the clutch free by driving with the clutch and brakes depressed at the same time. No more luck.

I pulled the access plug and had my wife press and release the clutch peddle several times, everything is moving internally like it should. I then used a strap to hold the clutch peddle down. I slipped a small screw driver through the access hole and could easily wiggle the clutch plate. I then released the clutch peddle and the clutch plate firmed up.

After that I used the strap again to hold the clutch peddle down and put the tractor in gear and tried rocking it. No luck freeing anything up that way.

Does anyone have any more ideas? Or is it time to break the tractor in half and see what is inside?

Thanks,
Ted