Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    New Member
    Join Date
    Mar 2012
    Posts
    7
    Location
    Gleason, WI
    Tractor
    International

    Default International 966 clutch/MCV issue...

    Hey everyone,
    Last fall my 966 started to act like the clutch was going out on it. It had good response and power untill 3 or 4 high. Also, the torque amplifier worked in high and low, but when you put it into high it would seem to slide in. But in 3 or 4 high when you pegged the throttle, the engine would rev up as it should but it was ovbvious I was not going faster... So I just tore it apart and put a new clutch in. It actually had a 14" clutch, i am guessing someone replaced it at one time with a 1066 one... So I put a new clutch, pressure plate and bearings in and got it put back together today and it basically is doing the same thing!!! As you can imagine I am not to happy... All of the clutch, dump valve and TA adjustments are how the book says they should be. I did not change the hydraulic fluid, but it is at the full mark and the tractor is usually kept out of the rain. The hydraulic fluid and filter was changed a year ago. Anyone have any ideas as to what is going on??? I did not resurface the flywheel when I was in there. With the TA acting that way it seems like maybe a MCV problem. I dont know. Thanks for any and all replies!
    Tom

  2. #2
    Platinum Member pjbci's Avatar
    Join Date
    Feb 2012
    Posts
    712
    Location
    Summit. Ms
    Tractor
    JD 4840, 450j, 310, komatsu D31px22, IH 1486, MF 135, MHF TO35

    Default

    Im afraid its your TA has gone out and the slippage you are getting is in the hyd clutch packs inside the front transmission case.

  3. #3
    New Member
    Join Date
    Mar 2012
    Posts
    7
    Location
    Gleason, WI
    Tractor
    International

    Default Re: International 966 clutch/MCV issue...

    But even with the TA forward the transmission still slips in 3 or 4 high when you punch the throttle. If the TA is back, on the low side, it does not seem to be as bad though. But I think it still slips some. If the TA were bad I didnt think that it would have an affect when you have the lever forward. Am I wrong?

  4. #4
    Super Member RickB's Avatar
    Join Date
    Sep 2000
    Posts
    7,038
    Location
    Eastern NY
    Tractor
    Case 885, JD 730D, Ford 4000

    Default Re: International 966 clutch/MCV issue...

    Quote Originally Posted by farmallboy1980 View Post
    But even with the TA forward the transmission still slips in 3 or 4 high when you punch the throttle. If the TA is back, on the low side, it does not seem to be as bad though. But I think it still slips some. If the TA were bad I didnt think that it would have an affect when you have the lever forward. Am I wrong?
    Low regulated circuit pressure and a failed low side sprag would let the TA slip in either mode in higher gears. Too bad you didn't stick a pressure gauge is the side of it prior to splitting the tractor.
    We have too much gun control.
    What we need is more idiot control.

  5. #5
    Platinum Member pjbci's Avatar
    Join Date
    Feb 2012
    Posts
    712
    Location
    Summit. Ms
    Tractor
    JD 4840, 450j, 310, komatsu D31px22, IH 1486, MF 135, MHF TO35

    Default

    Thats correct. Its gonna slip in either mode.

  6. #6
    New Member
    Join Date
    Mar 2012
    Posts
    7
    Location
    Gleason, WI
    Tractor
    International

    Default Re: International 966 clutch/MCV issue...

    Thanks guys. If I were to now put a pressure guage on it where would it go? I certainly can. I do have a manual so i will look at that too... I guess if I have to split it to reface the flywheel it was only about a 6 hour job for me to tear it apart and put her back together... Not nearly as bad as I thought it would be. Although I would rather not do that again...

  7. #7
    Platinum Member pjbci's Avatar
    Join Date
    Feb 2012
    Posts
    712
    Location
    Summit. Ms
    Tractor
    JD 4840, 450j, 310, komatsu D31px22, IH 1486, MF 135, MHF TO35

    Default

    I wouldnt worry about the flywheel. The clutch disk will fit itself to any grooves or irregularities.

  8. #8
    New Member
    Join Date
    Mar 2012
    Posts
    7
    Location
    Gleason, WI
    Tractor
    International

    Default Re: International 966 clutch/MCV issue...

    So if I can figure out how to test the pressures in the MCV, can this part be replaced without splitting the tractor again? Can the pump be replaced without splitting the tractor. It sounds like I probably should not just "baby" it for a while. Is this a good assumption?

  9. #9
    Platinum Member pjbci's Avatar
    Join Date
    Feb 2012
    Posts
    712
    Location
    Summit. Ms
    Tractor
    JD 4840, 450j, 310, komatsu D31px22, IH 1486, MF 135, MHF TO35

    Default

    The main pump can be replaced without splitting the tractor but your problem is more than likely in the hyd clutch packs that operate the TA. The seals in the clutch go bad causing a loss of presssure which allows slippage and destroys the clutch packs.

  10. #10
    Platinum Member pjbci's Avatar
    Join Date
    Feb 2012
    Posts
    712
    Location
    Summit. Ms
    Tractor
    JD 4840, 450j, 310, komatsu D31px22, IH 1486, MF 135, MHF TO35

    Default

    Sorry, I hit send too soon. So more than likely the TA will have to be replaced. Tractor will have to split again. TA is locacted in the front transmission case. Right behind the plate where you check pressure. One thing it could be is there are three oil tubes located behind the MCV that carry oil to the TA. The orings on these tubes could be leaking pressure there but once it starts slipping its usually ruined by then.

Page 1 of 2 12 LastLast

Similar Threads

  1. Loader B2320 Loader Issue?
    By maximus1277 in forum Kubota Owning/Operating
    Replies: 29
    Last Post: 09-04-2011, 12:36 AM
  2. International CUB Model ID
    By Dennis D in forum Owning/Operating
    Replies: 4
    Last Post: 02-15-2011, 07:40 AM
  3. T2310 Starting Issue
    By jonnykk in forum New Holland Owning/Operating
    Replies: 16
    Last Post: 11-25-2010, 11:06 AM
  4. TSC Post Hole Digger and BX2660...issue
    By delonm in forum Kubota Owning/Operating
    Replies: 11
    Last Post: 05-24-2010, 09:24 PM
  5. electrical issue?
    By psuedofarmer in forum Kioti Owning/Operating
    Replies: 6
    Last Post: 09-23-2004, 10:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2013 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.