Results 1 to 3 of 3
  1. #1
    New Member
    Join Date
    Oct 2004
    Posts
    7
    Location
    Ortonville, MI
    Tractor
    New Holland TC33

    Default Briggs Fuel Pump Problem 19.5 HP

    I have a late 90's craftsman mower with the original briggs 19.5 hp twin engine. Had an intermittent no start/rough running condition so I replaced plugs, fuel filter, fuel and vacuum lines. Condition still existed and I replaced coil and cleaned flywheel. Tractor was running, but surging a lot. I rebuilt carb and fuel pump. Fuel pump will now not draw fuel through the gas line. I replaced fuel pump body and installed another pump kit. Still no vacuum from fuel side of pump. I temporarily ran a clear fuel line to an auxilary fuel source to visually verify that gas was not going into pump. I can feel the vacuum from the vacuum line when turning engine over, but there is no vacuum at fuel port when vacuum line is attached. I've looked at the parts diagram and am 95% sure that the pump is installed correctly. Note: Engine runs when gas is poured in the carburetor. I don't know what to do next and would appreciate any ideas.

    Briggs Model No. 42E707 type 2631-E1
    Last edited by monsterdad1; 06-10-2011 at 09:58 PM.

  2. #2
    Veteran Member mostly_gas's Avatar
    Join Date
    Sep 2009
    Posts
    2,151
    Location
    Missouri
    Tractor
    in-between tractors

    Default Re: Briggs Fuel Pump Problem 19.5 HP

    Did you replace or rebuild the fuel pump? There is a sintered brass air filter on the back of the fuel pump that has to flow air for it to work. I had a problem with surging until I clean the brass and now it's gone.

  3. #3
    New Member
    Join Date
    Oct 2004
    Posts
    7
    Location
    Ortonville, MI
    Tractor
    New Holland TC33

    Default Re: Briggs Fuel Pump Problem 19.5 HP

    The pump is integrated into the carb, so it must be rebuilt. Cannot see any brass in pump, but did run a wire through all openings the last time I had it apart.

Similar Threads

  1. Fixing Startup Problems with JD 5220, 5320, 5420, 5520
    By ClemBert in forum John Deere Owning/Operating
    Replies: 57
    Last Post: 08-25-2013, 06:09 AM
  2. enlarging pond and deeping it.
    By boggen in forum Projects
    Replies: 5
    Last Post: 04-15-2011, 04:52 PM
  3. Oil & Fuel Fuel problems (algae)
    By rxk9394 in forum Kubota Owning/Operating
    Replies: 13
    Last Post: 01-08-2010, 04:36 PM
  4. Motor oil and other fuel additives
    By nosliw in forum Oil, Fuel & Lubricants
    Replies: 52
    Last Post: 02-17-2007, 12:12 AM
  5. New Low Sulfer Diesel in 2006 -PROBLEMS?
    By Bob_Skurka in forum Oil, Fuel & Lubricants
    Replies: 66
    Last Post: 01-13-2005, 07:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.