Results 1 to 2 of 2
  1. #1
    New Member
    Join Date
    Mar 2006
    Posts
    22

    Default Gradually loosing forward speed

    Hey guys,
    I've got a 2544 here with about 60 hrs on it. About 2 years ago and around 10 hours I modified the speed linkage unaderneath to increase the reverse speed. Over time I've noticed a decrease in performance in both forward and reverse speeds. Could it be that the linkage should be readjusted, or rebuilt, or could it be the transmission?

  2. #2
    Veteran Member JTKub's Avatar
    Join Date
    Apr 2005
    Posts
    1,560
    Location
    West Falls, NY
    Tractor
    Cub Cadet Z-Force 44

    Default Re: Gradually loosing forward speed

    Hard to say without examining full range of motion both forward and reverse. You have to get an idea by working the pedals and watching where the linkage attaches to the hydrostat itself. Problems with the hydrostatic drive are very rare with these. Low oil, or improper filter usually causes no go. 60hrs doesn't sound like you could possibly have a problem with the oil, but I assume you checked that.

    Joel
    Tractors of the past:
    2010 Cub Cadet Z-Force 44 fab
    2005 Cub Cadet 2544
    1979 Case 220
    2003 Yard Machines 17hp 42" transmatic (crap-matic)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2013 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.