Results 1 to 8 of 8
  1. #1
    New Member
    Join Date
    Mar 2013
    Posts
    11
    Location
    Bradenton ,Fl.
    Tractor
    Ford /Golden Jubilee

    Default hydraulics not working

    Working on jube this wknd, could not get hyd. to do anything. I have piston pump, friend stopped by said to remove plug from top of pump, screw in nipple ,hook up piece of tubing to hyd. fill hole and let cycle. Ran tractor for a while pumped oil thru tube still nothing. any suggestions. Thanks

  2. #2
    Epic Contributor Soundguy's Avatar
    Join Date
    Mar 2002
    Posts
    46,360
    Location
    Central florida
    Tractor
    ym1700, NH7610S, Ford 8N, 2N, NAA, 660, 850 x2, 541, 950, 951, 2000, 3000, 4000, 4600, 5000, 740, IH 'C' 'H', CUB, John Deere 'B', allis 'G', case VAC

    Default Re: hydraulics not working

    ok.. so the pump is primed.

    put plug back in.

    now pull plug ont he odd shaped 3x5 option cover under the right front of the seat and see if you have oil there.. might want to do the same deal with the nipple and hose.. or just start and shutdown fast.

    if you have oil there as well.. but no 3pt lift with the plug in.. then i'd pull the dipstick inspection cover and look up when running and 3pt control lifted and see if there is oil out of the mouth of the cyl.

    if not.. it may be a stuck unloader valve.

    one more thing.

    move the draft control lever around while left lever is up. if draft controal lever makes lift work.. cam pin may be worn or worn off and or the linkage needs adjusting.

    otherwise as I said.. unlader may be sticking.

    on a naa make sure you have a service mnual before removing the top cover as you need to remove the acorn nut and back off the back pressure valve prior to remoing cover.

    adjsut using alternate method without nuday tools.

  3. #3
    New Member
    Join Date
    Mar 2013
    Posts
    11
    Location
    Bradenton ,Fl.
    Tractor
    Ford /Golden Jubilee

    Default Re: hydraulics not working

    hydraulics not working-101_1451.jpghydraulics not working-101_1480.jpghydraulics not working-101_1482.jpg
    Thanks SG I'll try what you said But i dont have a cover under seat i have some kind of lever see pics.

  4. #4
    Epic Contributor Soundguy's Avatar
    Join Date
    Mar 2002
    Posts
    46,360
    Location
    Central florida
    Tractor
    ym1700, NH7610S, Ford 8N, 2N, NAA, 660, 850 x2, 541, 950, 951, 2000, 3000, 4000, 4600, 5000, 740, IH 'C' 'H', CUB, John Deere 'B', allis 'G', case VAC

    Default Re: hydraulics not working

    ok.. you have the rare remote valve. se if it is accidentally engaged. if it is.. there will be no 3pt hyds.

  5. #5
    New Member
    Join Date
    Mar 2013
    Posts
    11
    Location
    Bradenton ,Fl.
    Tractor
    Ford /Golden Jubilee

    Default Re: hydraulics not working

    I really don't know how to disengage, its not like pto lever or draft control where its in or out, this lever is spring loaded. Do I need to hold back on lever while using 3 point lift @ same time. Sorry for all the questions, just never seen one. I appreciate your help. Thanks

  6. #6
    Epic Contributor Soundguy's Avatar
    Join Date
    Mar 2002
    Posts
    46,360
    Location
    Central florida
    Tractor
    ym1700, NH7610S, Ford 8N, 2N, NAA, 660, 850 x2, 541, 950, 951, 2000, 3000, 4000, 4600, 5000, 740, IH 'C' 'H', CUB, John Deere 'B', allis 'G', case VAC

    Default Re: hydraulics not working

    it should have a neutral position, and either 1 or 2 engaged positions.. depending on if it is SA or DA. if it feels spring loaded and is centered.. it is likely in neutral.

    you can always remove a plug froma working port and see if you have oil at the remote port.

  7. #7
    New Member
    Join Date
    Mar 2013
    Posts
    11
    Location
    Bradenton ,Fl.
    Tractor
    Ford /Golden Jubilee

    Default Re: hydraulics not working

    There is a plug on top back behind fitting with 1/4 " tubing ,i will check that. also do you know antbody that might have a used top cover plate.Never had one of these remotes before
    i dont know what i would need that for.

  8. #8
    Epic Contributor Soundguy's Avatar
    Join Date
    Mar 2002
    Posts
    46,360
    Location
    Central florida
    Tractor
    ym1700, NH7610S, Ford 8N, 2N, NAA, 660, 850 x2, 541, 950, 951, 2000, 3000, 4000, 4600, 5000, 740, IH 'C' 'H', CUB, John Deere 'B', allis 'G', case VAC

    Default Re: hydraulics not working

    the come up for sale on ebay now and then.. generally hard to find as they were only used on the naa and that was a 53-54 machine. however.. that remote is a valuable piece too. you may simply want to keep it.. it's the easy way to add remote hyd options to your machine.

Similar Threads

  1. Hydraulics not working
    By obb in forum Hydraulics
    Replies: 6
    Last Post: 02-10-2013, 08:08 PM
  2. Hydraulics not working
    By CATMAN3208 in forum Hydraulics
    Replies: 3
    Last Post: 11-24-2012, 10:36 AM
  3. Hydraulics stopped working
    By twinsticks in forum Kubota Owning/Operating
    Replies: 2
    Last Post: 08-31-2012, 09:20 PM
  4. Hydraulics stopped working
    By JayBear in forum Hydraulics
    Replies: 4
    Last Post: 11-26-2011, 11:53 AM
  5. hydraulics are not working
    By GB007 in forum Kubota Owning/Operating
    Replies: 1
    Last Post: 02-14-2008, 09:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2013 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.