Results 1 to 3 of 3
  1. #1
    New Member
    Join Date
    Sep 2009
    Posts
    1

    Default David Brown

    I'm having trouble with the hydraulics on my David Brown. It will go up as soon as the tractor is turned on, but the controls wouldn't let it come back down. After you shut the tractor off then it will come back down. Had it to the tractor repair shop and they couldn't fix it. Anyone have any ideas on how to get it to work?

  2. #2
    Old Timer Soundguy's Avatar
    Join Date
    Mar 2002
    Posts
    51,823
    Location
    Central florida
    Tractor
    ym1700, NH7610S, Ford 8N, 2N, NAA, 660, 850 x2, 541, 950, 941D, 951, 2000, 3000, 4000, 4600, 5000, 740, IH 'C' 'H', CUB, John Deere 'B', allis 'G', case VAC

    Default Re: David Brown

    i'm not familair with their hyds.. but sounds like a control valve is stuck.. ie.. intake, and perhaps exhaust.. depending on how they are linked.

    soundguy

  3. #3
    Platinum Member
    Join Date
    Dec 2008
    Posts
    898
    Location
    Buffalo, New York
    Tractor
    318 John Deere, 4200 John Deere, 1947 John Deere "M"

    Default Re: David Brown

    Might want to look over here at these forums:

    YT Site Search

    Type David Brown in the extreme upper right search box! ~Scotty

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2016 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.