Results 1 to 5 of 5
  1. #1
    New Member
    Join Date
    Apr 2010
    Posts
    4
    Location
    Alabama
    Tractor
    Ford 1710, 1986

    Default Ford 770 loader questions

    Hello
    I have a 1986 Ford 1710 with a front end loader Ford 770B.
    First problem:I noticed when raising or lowering my bucket it is not smooth but jumpy. Could somebody tell me the fix for this?

    Second Problem: I was backblading this morning and now my bucket will not tilt foward or back but it still goes up and down.
    Did I blow a cylinder seal on the tilt cylinder(s) or something else?

    Your responses are appreciated.
    Thanks Dave

  2. #2
    Veteran Member
    Join Date
    Dec 2009
    Posts
    1,001

    Default Re: Ford 770 loader questions

    I am assuming this all just started, so if hydraulic fluid level is fine, the first thing to do before any other steps is unhook any quick disconnects and rehook them to see if this helps.

  3. #3
    New Member
    Join Date
    Apr 2010
    Posts
    4
    Location
    Alabama
    Tractor
    Ford 1710, 1986

    Default Re: Ford 770 loader questions

    Thanks MMurphy
    I'll try that.

  4. #4
    Gold Member Kevin M's Avatar
    Join Date
    Nov 2009
    Posts
    383
    Location
    goshen NY
    Tractor
    48" bobcat walk behind , 60" Dixie Chopper Classic , 755 John Deere 4x4 70 ldr belly mower etc etc , 7610 Ford 4x4 7412 ldr and 10 ft rhino hogg

    Default Re: Ford 770 loader questions

    Sounds like an issue in the valve to me ,

  5. #5
    New Member
    Join Date
    Apr 2010
    Posts
    4
    Location
    Alabama
    Tractor
    Ford 1710, 1986

    Default Re: Ford 770 loader questions

    mmurphy
    Finally got some time to investigate my problem. Found that one of the hydraulic line quick connects disconnected. Put it back on and it is working now.
    Thanks for your advice and all others that provided information.

Similar Threads

  1. Front loader - Ford I9-I18...specs and parts?
    By Specop_007 in forum Attachments
    Replies: 0
    Last Post: 08-25-2009, 12:18 PM
  2. FORD LOADER
    By KJO in forum New Holland Owning/Operating
    Replies: 7
    Last Post: 03-23-2006, 10:04 AM
  3. Smoke or condensation?
    By michaelTS354 in forum Chinese Tractors
    Replies: 12
    Last Post: 01-16-2006, 03:56 PM
  4. Ballast Ballast
    By JDGREEN4ME in forum John Deere Owning/Operating
    Replies: 6
    Last Post: 10-17-2002, 10:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2016 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.