Results 1 to 7 of 7
  1. #1
    New Member
    Join Date
    Dec 2010
    Posts
    4
    Location
    Pensacola and Paxton Florida
    Tractor
    Kubota M135 Kubota MX5100 John Deere 5525 ASV RC100 Bobcat T320 and T190

    Default 2007 ASV RC 100 - Heard a loud POP and then no Hydraulics

    I have a 2007 RC 100. I was using the machine to clear some light brush with a Davco brush cutter. Everything was working well when I heard and felt a loud POP. The unit immediately stopped forward movement. The arms would not move up or down. Especially down since I couldn't get the door open with the arms up. That sucks. The brush cutter that was operating began to slow. The joysticks did not operate. No Hydraulics at all. No high flow or low flow. The engine continued to run. I did not notice any smoke, debris or oil on the ground around the machine. I am not a mechanic and barely have enough sense to run this machine, I recognize that. But, I could not identify anything visually that would indicate what would be the issue.
    I had just had the turbo charger replaced and this was my first chance to use the machine. Because the engine would crank and run smoothly after the loud Pop I don't think the turbo charger had anything to do with this issue.
    Any suggestions are appreciated.

  2. #2
    Super Member Scooby074's Avatar
    Join Date
    Aug 2006
    Posts
    6,242
    Location
    Nova Scotia
    Tractor
    BX 25, ZD 326

    Default Re: 2007 ASV RC 100 - Heard a loud POP and then no Hydraulics

    Loud pop, no hydraulics and the engine runs...

    Im going to assume that there are multiple pumps . If I was to guess, id bet that whatever coupling was between the pump(s) and engine broke in some way...

  3. #3
    New Member
    Join Date
    Dec 2010
    Posts
    4
    Location
    Pensacola and Paxton Florida
    Tractor
    Kubota M135 Kubota MX5100 John Deere 5525 ASV RC100 Bobcat T320 and T190

    Default Re: 2007 ASV RC 100 - Heard a loud POP and then no Hydraulics

    Had a real mechanic come look at my machine this morning. He had the same suggestion that you did. He placed a pressure gauge on some type of hydraulic port in the engine compartment and had me start the engine. No pressure. Engine runs fine. Now I am having to find a roll back wrecker to come get it and take it to the shop. Will let you know. Thanks

  4. #4
    Super Member Scooby074's Avatar
    Join Date
    Aug 2006
    Posts
    6,242
    Location
    Nova Scotia
    Tractor
    BX 25, ZD 326

    Default Re: 2007 ASV RC 100 - Heard a loud POP and then no Hydraulics

    No worries! Hope it doesnt cost you too much to get it back to work.

  5. #5
    New Member
    Join Date
    Dec 2010
    Posts
    4
    Location
    Pensacola and Paxton Florida
    Tractor
    Kubota M135 Kubota MX5100 John Deere 5525 ASV RC100 Bobcat T320 and T190

    Default Re: 2007 ASV RC 100 - Heard a loud POP and then no Hydraulics

    It's confirmed, I'm and idiot and do not need to be operating dangerous machinery.
    I had a roll back wrecker drag my machine up on the deck and hall it to the local repair shop. Once there they determined that I had apparently hit something causing the door to become ajar thereby activating the safety switch and stopping all hydraulics. Makes sense. I was cruising along on uneven terrain and probably did hit something causing the door safety switch that had become loose to break contact. I had opened in closed the door several times in an attempt to get the machine running but never looked at the contact. Whatever I had hit was just enough of a bump to cause the loose contact to move enough so that opening and closing the door did not allow it to re-engage.
    I asked why the mechanic that came to the site could not get pressure on the test gauge he applied to the hydraulics. Apparently, you have to "dead head" the hydraulics to test them and this guy didn't.
    So, cheap fix but expensive lesson.

  6. #6
    Elite Member wdchyd's Avatar
    Join Date
    Apr 2010
    Posts
    2,719
    Location
    Hooksett, NH
    Tractor
    Kubota B2320

    Default Re: 2007 ASV RC 100 - Heard a loud POP and then no Hydraulics

    Glad you found the problem.....Chalk it up to education.....You'll know the next time

    Having a broken coupler (or worse a snapped hyd pump shaft) can be a VERY expensive lesson.......Good thing it wasn't that....
    2010 Kubota B2320 FEL & BH65
    If it ain't fixed don't broke it!

    http://www.tractorbynet.com/content/...-month-wdchyd/

  7. #7
    Super Member Scooby074's Avatar
    Join Date
    Aug 2006
    Posts
    6,242
    Location
    Nova Scotia
    Tractor
    BX 25, ZD 326

    Default Re: 2007 ASV RC 100 - Heard a loud POP and then no Hydraulics

    Dang safety switches!!!

    Glad you got it fixed up!

Similar Threads

  1. Looking at an 2008 ASV PT-100
    By Dwbecker85 in forum Construction Equipment
    Replies: 6
    Last Post: 01-04-2013, 01:11 AM
  2. ASV RC 100
    By jlhenry in forum Parts/Repairs
    Replies: 1
    Last Post: 04-10-2012, 09:50 PM
  3. ASV PT 100 AC
    By trailbuilder in forum Construction Equipment
    Replies: 4
    Last Post: 08-01-2011, 01:31 PM
  4. ASV PT 100 Forestry
    By cat 297c in forum Buying/Pricing/Comparisons
    Replies: 11
    Last Post: 03-28-2009, 11:37 AM
  5. ASV PT-100
    By QwikDraw in forum Construction Equipment
    Replies: 5
    Last Post: 12-30-2007, 11:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.