Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16
  1. #11
    New Member
    Join Date
    May 2011
    Posts
    2
    Tractor
    JD6320

    Default Re: Deere 6420 rough running

    I have the same fuel problem. Checked everything. Diagnostics say solenoid bad in injector pump. Dealer suggest putting a rebuilt one on. He also stated they are having a lot of problems with these injectors. Seems John deere would make them right or at least help. Please let us know if you have any succes with corporate!!!

  2. #12
    New Member
    Join Date
    May 2011
    Posts
    4
    Tractor
    8295R

    Default Re: Deere 6420 rough running

    If your fuel filter has the glass sediment bowl on it make sure the gasket is still between the filter and the sediment bowl because it will run fine for a while before it starts to suck air from here without leaking fuel also just go ahead and replace all the fuel hose and replace the squeeze style hose clamps with good screw type

  3. #13
    New Member
    Join Date
    May 2011
    Posts
    2
    Tractor
    JD6320

    Unhappy Re: Deere 6420 rough running

    Thanks TX deere, we have checked all those things and replaced all fuel lines. Talked with the dealer again yesterday, my problem is not the first to to come through that dealership. Several more have had the same issue. Only thing that seems to fix the problem is a new injector pump. They stated that Chevy had used the same pump on some engines and were experienceing similar problems. Seems pump replacement is the only option. I have truly tried every other potential issue to no avail. Will let u guys know if it works, I have one on the way!!

  4. #14
    Veteran Member Jerry/MT's Avatar
    Join Date
    Feb 2008
    Posts
    1,984
    Location
    Western Montana
    Tractor
    New Holland TD95D, Ford 4610 & Ferguson TO-30

    Default Re: Deere 6420 rough running

    Quote Originally Posted by Jeff Thomas View Post
    I have a 6420 4wd that runs fine most of time. However, every once in a while it runs rough sounding as though air is in line or it has bad fuel. If you turn the tractor off then on again its solved the problems mist of the time. Changed the filters and checked for air but still does it every once in awhile. I called a John deere mechanic and he said it could have something to do with a sensor in the fuel injector pump. They are 3000 dollars. Anybody have similar problems?
    It sounds like fuel delivery issues. I would make sure that you don't have some crud in the fuel tank that's clogging the tank outlet and/or fuel line itermittently. With low fuel in the tank, you might consider removing the drain collecting the drained fuel and seeing what you have in the tank. It might surprise you! Water and algae are common problems with diesel fuel. Was there any evidence of debris in your fuel line or the filter when you changed them out? (I bought a used tractor out of New Mexico and I had aproblem ith water in the fuel. It surprised me because the humidity is very low there but the PO might have had a contaminated storage tank.)

    My neighbor has a 6420 and he's had a lot of problesm with lift pumps (multiple replacements) but as far as I know, that has resulted in an inability to start. However intermittent operation of the lift pump can cause a problem with fuel delivery.

    Make sure all the fuel connections are tight so they don't suck air.

    Don't replace/rebuild the pump until you have eliminated all the more likely possibilities.

  5. #15
    New Member
    Join Date
    Jul 2011
    Posts
    13
    Location
    melbourne australia

    Default Re: Deere 6420 rough running

    if tractor is common rail do not open injector lines. if it is common rail it sounds like a suction control valve your jd mech prob checked codes look out for ecu 1347.07

  6. #16
    New Member
    Join Date
    Jan 2014
    Posts
    1
    Location
    Malvern AR
    Tractor
    John Deere 6320

    Default Re: Deere 6420 rough running

    I have a 6320 that on a cold day after the first startup of the day it will run for about 10 minutes and then start missing badly. Shutting it down for about a minute or two and recranking solves the problem for the rest of the day. This tractor never has this problem on a hot day or during the summer. Anybody had this problem?

Page 2 of 2 FirstFirst 12

Similar Threads

  1. John Deere Noise Canceling Headphones
    By Fug1000 in forum Kubota Owning/Operating
    Replies: 52
    Last Post: 11-08-2010, 09:57 PM
  2. Why is my Branson running rough?
    By Felix in forum Century & Branson
    Replies: 5
    Last Post: 09-11-2010, 05:41 PM
  3. Mowing John Deere Rough Cut Mower
    By Drpower in forum John Deere Owning/Operating
    Replies: 3
    Last Post: 01-02-2009, 10:26 AM
  4. 2165 Running rough and blowing black smoke
    By Wanavet in forum Cub Cadet Tractors
    Replies: 9
    Last Post: 09-21-2005, 03:18 PM
  5. Home Depot
    By BrokerBob in forum John Deere Buying/Pricing
    Replies: 29
    Last Post: 07-12-2002, 09:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2013 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.