Results 1 to 2 of 2
  1. #1
    New Member
    Join Date
    Nov 2012
    Posts
    2
    Location
    Ivanhoe, NC
    Tractor
    JD 6430

    Default 6430 Premium SCV Quick Connector problem

    I have a 6430 Premium that has an ongoing problem with the scv quick connectors. I have replaced about 10 of them since the tractor was puchased new. They will start allowing the hydraulic hoses to blow out and then start puking hydraulic oil. Any help will be greatly applreciated.

  2. #2
    Super Member JerryG's Avatar
    Join Date
    Apr 2000
    Posts
    7,229
    Location
    Northwest Arkansas
    Tractor
    MF 1440-4 PowerShuttle

    Default Re: 6430 Premium SCV Quick Connector problem

    Make sure the release ring is back in the locked position.

Similar Threads

  1. More Trouble with the 6430 Premium.
    By Edward. S in forum John Deere Owning/Operating
    Replies: 8
    Last Post: 06-25-2015, 01:15 PM
  2. JD 6430 Premium at the Dealers!
    By Edward. S in forum John Deere Buying/Pricing
    Replies: 31
    Last Post: 05-29-2012, 06:52 AM
  3. Front and Rear Duals on 6430 Premium?
    By harsinfamfarms in forum John Deere Ag Tractors
    Replies: 15
    Last Post: 03-05-2012, 06:52 AM
  4. Used John Deere 6430 Premium.
    By Edward. S in forum John Deere Buying/Pricing
    Replies: 24
    Last Post: 07-10-2010, 11:02 PM
  5. 6430 Premium Tractor (95 PTO hp)
    By RFB in forum John Deere Buying/Pricing
    Replies: 10
    Last Post: 02-11-2008, 08:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2016 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.