Results 1 to 2 of 2
  1. #1
    New Member
    Join Date
    Jul 2011
    Posts
    2
    Tractor
    Scotts (John Deere) S2554, 25hp v twin kohler, 54" mower deck

    Default Scotts(John Deere) S2554 Back up and Brake problem.

    I just bought a used Scotts (John Deere) S2554 lawn tractor 25 hp Kohler v twin, 54" mower deck. This tractor is in great shape. But, the mower, pto engine interface has a problem. The engine runs find in low and high RPMS as long as you do not start up the PTO (mower). When you pull up (on) the PTO switch, at low RMPs, the engine runs and the mower runs. At high RMP the engine will not run and wants to die out. However when you push on the brake pedal with the pto on, the engine and mower run perfect. When you release the brake, the engine wants to stop running. When you have the PTO on and go in reverse the mower still runs and is suppose to stop. The seat safety switch doesnt work either. It is like the safety features are not working properly. It seems that the brakes safety feature is working in reverse. So again, when the brake is held down the engine and mower fun fine. Release the brake and the engine doest run and almost dies. Push in the PTO (Off) and the engine run fine again. At first I thought it was the Gas pump. So I replaced it with a new unit. But that was not the problem. Anyway HELP!!! Thanks

    PS Now I find that if I hold the PTO switch all the way up in the reverse position, the engine and the mower work find? Help!!!!
    Ted
    Last edited by tkcenterline; 07-03-2011 at 10:26 AM.

  2. #2
    New Member
    Join Date
    Jul 2011
    Posts
    2
    Tractor
    Scotts (John Deere) S2554, 25hp v twin kohler, 54" mower deck

    Default Re: Scotts(John Deere) S2554 Back up and Brake problem.

    PS Now when I start the engine release the brake and pull up the PTO it stays in the up position and I can mow in forward and reverse. But If I hit a bump the switch goes into the middle position and the engine stops. When this happens I immediately push down on the PTO and the engine run and the mower stops. IT appears to be the middle position that is not working. Could The problem be the PTO?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.