Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 40
  1. #21
    Veteran Member JerryK's Avatar
    Join Date
    Feb 2004
    Posts
    1,482
    Location
    Vanderbilt, Michigan, USeh?
    Tractor
    Mahindra 5035, JD 2240, 420

    Default Re: Engine runs 20 seconds, then quits

    It could be blocked airflow... which means intake AND exaust. [ someone stick a potato(e) up your kiester..?? ] Semi blocked fuel line/filter will do it... lets enough gas thru slowly to run until you use that portion up...then you have to wait until the line gets more fuel in it. Flywheel electronic module will heat up and do that sometimes if it is bad.....
    48" CID QA forks, 6' EverythingAttachments Land Plane, 78" JRW rear blower, homemade 1 ton rear weight, 6' Ford rear blade, homemade boom, big homemade 3pt box/carrier, 8" wood chipper

  2. #22
    Epic Contributor
    R.I.P.
    jinman's Avatar
    Join Date
    Feb 2001
    Posts
    21,014
    Location
    Texas - Wise County - Sunset
    Tractor
    NHTC45D, NH LB75B, Ford Jubilee

    Default Re: Engine runs 20 seconds, then quits

    I'm a bit slow with just the engine number, but now I realize it is a Kawasaki engine. The carburetor and fuel pump work similar to the Briggs & Stratton and can be checked with the same air pressure on the fuel inlet. The valve is probably about twice as expensive though at around $20.

    If it dies and won't start, but will try to start if you pour a little gas down the intake, it's a fuel feed problem, pure and simple.
    Jim


  3. #23
    New Member
    Join Date
    Aug 2012
    Posts
    17
    Location
    ALABAMA
    Tractor
    JD 5045E

    Default

    Are you running ethanol fuel? Try a bottle of seafoam. Most mechanics will put seafoam in your vehicle/tractor/4wheeler or whatever and then charge you a outrageous price for something they made up that was causing the problem.

  4. #24
    Gold Member
    Join Date
    Jun 2013
    Posts
    253
    Location
    N. GA
    Tractor
    LX188/445/755

    Default Re: Engine runs 20 seconds, then quits

    Quote Originally Posted by bh3zfc View Post
    Are you running ethanol fuel? Try a bottle of seafoam. Most mechanics will put seafoam in your vehicle/tractor/4wheeler or whatever and then charge you a outrageous price for something they made up that was causing the problem.
    The Seafoam deal is true. I have heard that this stuff will smooth out engine problems after one tank. Not sure they use a whole bottle.
    I use in to treat and clean Diesel fuel tanks that have been sitting with old fuel.

    I have learned to replace fuel lines if you suspect trash problems. Especially the line from the filter to the carb.
    I have found where small pieces of fuel line clogged up the needle/jet. This is related to Ethanol and age of the lines.

    When it stops pull the plugs out to see if they are wet with fuel.

    It's not that expensive to replace the line all the way from the tank to the carb.

  5. #25
    Gold Member
    Join Date
    Jul 2003
    Posts
    394
    Location
    South Central TEXAS
    Tractor
    Main: Case 235

    Default Re: Engine runs 20 seconds, then quits

    I'm sure you've been waiting with intense anticipation for the outcome of this saga. Well, wait no more.

    I have to admit here, that I did not adhere to Jim's troubleshooting method. (It takes a great effort to pull my compressor from the barn and haul it over to the equipment shed. That said, I thought long and hard again about the symptoms. It had to be fuel starvation! It would run 27 seconds at full throttle, and about 33 seconds at an idle. Not knowing the rate of fuel consumption, I convinced myself that this must be the amount of fuel in the bowl, and that it was not being replenished by a sticking needle valve. I bought the valve ($18), and a little O-ring ($1) that I may have messed up with my multiple dis-assembly/ assembly activities.

    I put it all back together and it started right up (as normal). It ran for 27 seconds and died (as the new normal). I could see there was fuel in the filter. I tried to re-start it immediately and there was a tremendous backfire from the exhaust. I was glad there was nothing flammable nearby, and my hearing came back within a few minutes. This told me there was too much fuel, and not enough spark?
    Out of shear desperation now I installed the $2 spark plug I had previously bought. (I didn't install it before this time as the symptoms did not fit.) The mower started right up (as normal). I realized I had counted to 53 seconds when my brain said, 'hey, dummy. That's longer than before.' 2 hours, and the side and front yard later, I put it away in the shed.

    I don't know why I make my life more complicated than it really has to be. Yet another reminder to always try the simplest, and least expensive, things first. GreenRules and Midniteoyl rule this thread. Thanks to everyone's assistance!
    I believe I found the missing link between animal and civilized man. It is us. -Konrad Lorenz

  6. #26
    Veteran Member
    Join Date
    May 2013
    Posts
    2,253
    Location
    Knox, In,
    Tractor
    Ford 3400, Gizmow ZTR, Simplicity 7116H

    Default Re: Engine runs 20 seconds, then quits

    Ahem..


    Glad you got it fixed!


    Had 2 lawn mowers AND my brothers Mazda CX7 do the exact same thing recently.

  7. #27
    Super Member Kyle_in_Tex's Avatar
    Join Date
    Oct 2002
    Posts
    5,480
    Location
    Giddings, Texas
    Tractor
    JD 4310,JD5420

    Default Re: Engine runs 20 seconds, then quits

    Just saw this and glad you got it fixed. It can sometimes be the spark, but where in the system is the heat/load causing the problem? Sometimes it's the plug, others it's the coil, and old school stuff has capacitors that can be the culprit.
    Haven't heard from you in a while, how's everything going?
    there are 2 kinds of oats. Oats in front of a horse, and oats behind the horse.

  8. #28
    Epic Contributor
    R.I.P.
    jinman's Avatar
    Join Date
    Feb 2001
    Posts
    21,014
    Location
    Texas - Wise County - Sunset
    Tractor
    NHTC45D, NH LB75B, Ford Jubilee

    Default Re: Engine runs 20 seconds, then quits

    Well, if you can't get a compressor handy, then there is the fuel down the carb inlet test. Either is checking fuel starvation. The important thing is that you stuck with it anf found the problem. I'm a little surprised that a spark plug failed with those symptoms. Interesting problem. . .
    Jim


  9. #29
    Gold Member
    Join Date
    Jun 2013
    Posts
    253
    Location
    N. GA
    Tractor
    LX188/445/755

    Default Re: Engine runs 20 seconds, then quits

    Quote Originally Posted by jinman View Post
    . I'm a little surprised that a spark plug failed with those symptoms. Interesting problem. . .
    I wonder if Jazzdad may also have a coil problem also. I have hear of coils shutting down with heat, and somewhat hard to troubleshoot.
    Often it's the wire vs. the coil.
    I would keep a close eye on that side. You can tell lots by looking at how the plugs are firing by removal.

  10. #30
    Epic Contributor Soundguy's Avatar
    Join Date
    Mar 2002
    Posts
    49,251
    Location
    Central florida
    Tractor
    ym1700, NH7610S, Ford 8N, 2N, NAA, 660, 850 x2, 541, 950, 941D, 951, 2000, 3000, 4000, 4600, 5000, 740, IH 'C' 'H', CUB, John Deere 'B', allis 'G', case VAC

    Default Re: Engine runs 20 seconds, then quits

    Quote Originally Posted by jinman View Post
    . I'm a little surprised that a spark plug failed with those symptoms. Interesting problem. . .
    I agree. a timed spark plug failure?

    almost had to be a cracked insulator that heated up fast and let spark short thru at a very small place/gap.. etc..
    souNdguy

    sent from my NOKIA LUMIA

Page 3 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. Ariens S14-H runs for 3 - 4 seconds and then dies
    By rspack in forum Parts/Repairs
    Replies: 3
    Last Post: 11-21-2012, 07:35 PM
  2. Engine runs then quits
    By Mal AC in forum Simplicity
    Replies: 6
    Last Post: 10-03-2012, 11:38 AM
  3. 3215 starts, runs and then dies after 2-3 seconds
    By Timmanny in forum Mahindra Owning/Operating
    Replies: 31
    Last Post: 06-13-2012, 04:12 PM
  4. Cub 1450 Engine runs for 30/45 seconds
    By mayersr in forum Cub Cadet L&G
    Replies: 10
    Last Post: 07-24-2007, 02:42 PM
  5. Beat up B7100 runs rough for initial 30 seconds?
    By SteveM in forum Kubota Owning/Operating
    Replies: 2
    Last Post: 03-24-2006, 05:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.