Page 1 of 4 1234 LastLast
Results 1 to 10 of 40
  1. #1
    Gold Member
    Join Date
    Jul 2003
    Posts
    394
    Location
    South Central TEXAS
    Tractor
    Main: Case 235

    Default Engine runs 20 seconds, then quits

    This has got me baffled. My JD rider has a PA540A engine in it. It starts very quickly, but then dies after 20 seconds of full throttle running. If I start it then quickly throttle back, it will run for 30 seconds. The fuel tank is not creating a vacuum, because the same symptoms apply if I leave the gas cap off. The fuel shutoff solenoid on the carb is opening, and the float is allowing fuel to flow quite well without the engine running, even through the fuel pump. All the fuel pump baffles/ bellows seem intact and flexing. Nothing seems gummed up in there.

    It seems fuel starved to me. Perhaps a fuel line collapsing? I tried dripping gas into the throat of the carb at low speed. It backfired a bit, but still died at the same time (30 seconds)

    I have not changed the plug. It just seems too consistent to be the plug heating up and then going bad at the same time, every time.

    Replace the fuel lines first (all 5 feet of them)?
    Spark plug first?
    Remove & thoroughly clean the carb?

    Thanks in advance.
    Bret
    I believe I found the missing link between animal and civilized man. It is us. -Konrad Lorenz

  2. #2
    Epic Contributor Soundguy's Avatar
    Join Date
    Mar 2002
    Posts
    48,755
    Location
    Central florida
    Tractor
    ym1700, NH7610S, Ford 8N, 2N, NAA, 660, 850 x2, 541, 950, 941D, 951, 2000, 3000, 4000, 4600, 5000, 740, IH 'C' 'H', CUB, John Deere 'B', allis 'G', case VAC

    Default Re: Engine runs 20 seconds, then quits

    sounds like a fuel issue.. maybee stuck float needle.. had a brigs do that.
    souNdguy

    sent from my NOKIA LUMIA

  3. #3
    Elite Member
    Join Date
    Jul 2006
    Posts
    4,409
    Location
    Northwest, WA

    Default Re: Engine runs 20 seconds, then quits

    "and the float is allowing fuel to flow quite well"

    Wow.
    ::Sent from a standard desktop keyboard::

    My Photobucket

  4. #4
    Veteran Member GreenRules's Avatar
    Join Date
    Apr 2002
    Posts
    1,458
    Location
    Limerick, Maine
    Tractor
    John Deere 4110, 325,Gt225,, 110, XUV550S4, Kubota L275

    Default Re: Engine runs 20 seconds, then quits

    Believe it or not, I have had a plug do that.

  5. #5
    Bronze Member glgeek's Avatar
    Join Date
    Mar 2012
    Posts
    60
    Location
    minnesota
    Tractor
    X728

    Default Re: Engine runs 20 seconds, then quits

    water in the fuel?

    fresh fuel and drain the bowl.

    just a thought.

  6. #6
    Member
    Join Date
    Feb 2013
    Posts
    35
    Location
    Pennsylvania
    Tractor
    John Deere 318, John Deere X758, Kubota L4200 GST

    Default Re: Engine runs 20 seconds, then quits

    Check the fuel filter.

    My neighbor had that exact same problem two weeks ago when he called me to look at his JD.
    I changed his gas filter and it's been running like new ever since. I never saw so much sludge in a fuel filter before. Come to find out his grandson had used the gas can to drain an old fuel oil tank and never cleaned the gas can out again before refilling it with gas.

    It's a good thing that sludge did not make it to the carburetor. Short of pulling the gas tank of the GT and cleaning it out, I told my neighbor to keep another new gas filter on hand.

  7. #7
    Gold Member
    Join Date
    Jul 2003
    Posts
    394
    Location
    South Central TEXAS
    Tractor
    Main: Case 235

    Default Re: Engine runs 20 seconds, then quits

    Soundguy and Willl: With the carb bowl removed, the fuel flows freely with the float hanging down (open). When I push it up, the fuel flow stops.

    GreenRules: I have read this around the Interwebs. I hope to get a plug today to try this.

    Glgeek: It's fresh fuel. I drained what was in there from last year, even though it had stabilizer in it and didn't smell 'sweet'.

    Oldoak: Fuel filter has no restriction. Fuel flows well through it.

    I will report my findings.
    I believe I found the missing link between animal and civilized man. It is us. -Konrad Lorenz

  8. #8
    Elite Member
    Join Date
    Jul 2006
    Posts
    4,409
    Location
    Northwest, WA

    Default Re: Engine runs 20 seconds, then quits

    Quote Originally Posted by JazzDad View Post
    Soundguy and Willl: With the carb bowl removed, the fuel flows freely with the float hanging down (open). When I push it up, the fuel flow stops..
    Yes, I read that in your first post.
    ::Sent from a standard desktop keyboard::

    My Photobucket

  9. #9
    Bronze Member glgeek's Avatar
    Join Date
    Mar 2012
    Posts
    60
    Location
    minnesota
    Tractor
    X728

    Default Re: Engine runs 20 seconds, then quits

    Bret,

    one thing you didn't mention, is when you start it and it runs for 20 seconds and dies. does it do the same thing when you engage the starter again right away? or do you have to wait before it will start again?

    ba
    Last edited by glgeek; 06-02-2013 at 11:18 PM.

  10. #10
    Epic Contributor Soundguy's Avatar
    Join Date
    Mar 2002
    Posts
    48,755
    Location
    Central florida
    Tractor
    ym1700, NH7610S, Ford 8N, 2N, NAA, 660, 850 x2, 541, 950, 941D, 951, 2000, 3000, 4000, 4600, 5000, 740, IH 'C' 'H', CUB, John Deere 'B', allis 'G', case VAC

    Default Re: Engine runs 20 seconds, then quits

    Quote Originally Posted by Willl View Post
    Yes, I read that in your first post.
    it was a good thing to doublecheck though. can';t tell you how many tractors I've fixed for start-run-stall afte rhte owner said it had fuel flow, by checkign the flaot needle.

    not always it. but never hurts to check twice. that's a common prob on some smaller engines like brigs with no pulsa pump.
    souNdguy

    sent from my NOKIA LUMIA

Page 1 of 4 1234 LastLast

Similar Threads

  1. Ariens S14-H runs for 3 - 4 seconds and then dies
    By rspack in forum Parts/Repairs
    Replies: 3
    Last Post: 11-21-2012, 08:35 PM
  2. Engine runs then quits
    By Mal AC in forum Simplicity
    Replies: 6
    Last Post: 10-03-2012, 12:38 PM
  3. 3215 starts, runs and then dies after 2-3 seconds
    By Timmanny in forum Mahindra Owning/Operating
    Replies: 31
    Last Post: 06-13-2012, 05:12 PM
  4. Cub 1450 Engine runs for 30/45 seconds
    By mayersr in forum Cub Cadet L&G
    Replies: 10
    Last Post: 07-24-2007, 03:42 PM
  5. Beat up B7100 runs rough for initial 30 seconds?
    By SteveM in forum Kubota Owning/Operating
    Replies: 2
    Last Post: 03-24-2006, 06:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.