Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11
    Gold Member
    Join Date
    Jan 2010
    Posts
    498
    Location
    East Coast
    Tractor
    JDs:

    Default Re: JD 997Z mower problem

    Quote Originally Posted by Tlday View Post
    Well, I let it set for a couple of hours and tried it again. I'm still getting the same problem. However, it appears that it is better than it was. I have noticed that sometimes turning the ignition to off briefly and then turning it back on will coax it to keep running. Whatever the problem is, it is causing me to really hate this mower.
    I know! When mine was new, I took it back to the Dealer and they said "we tried all day to make it do what you said and it worked fine for us"....ahhhh! Now each time it stalls/happens, I wonder is this the time I will not be able to get it going? the only thing I've been able to do, and i'm not sure it helps but I do get going. is when it starts to stall (because it thinks either i) no one is in the seat or ii) the break is still on...as I move the arms in...I quickly put them back into neural position keeping the engine running - then move them back out very very slow...it seems to be a bit of a work-a-round. Oh, forgot to mention, let down the park break very very slow as well. so that's...park break down slow and arms out slow. and smooth for both. WHAT A PAIN!

  2. #12
    New Member
    Join Date
    Jan 2014
    Posts
    24
    Location
    ider al
    Tractor
    John Deere 750/1050

    Default

    Quote Originally Posted by 9973720wb19 View Post
    since this is a JD forum, maybe you guys could help with my JD 997 Z mower. I have had an intermittent problem since day one...6/08. The safty feature will not allow the mower to start without park break on...fine. However, sometimes, after I start it (break on) then go to put the break down/off...the engine stalls. I took it to the dealer and they said they could not make this happen. I just did my spring tune and I had this issue one out of five fine starts.

    Any advise or information that would help in talking to my dealer?

    Thanks
    There is a switch along the relays the best I remember it is a switch that when you bounce up & down on the seat on rough ground it keep the mower going. But if you remain up for more then a second or to it will kill the mower

  3. #13
    New Member
    Join Date
    May 2014
    Posts
    5
    Location
    Oxford, OH
    Tractor
    997Z

    Default Re: JD 997Z mower problem

    Quote Originally Posted by 9973720wb19 View Post
    I know! When mine was new, I took it back to the Dealer and they said "we tried all day to make it do what you said and it worked fine for us"....ahhhh! Now each time it stalls/happens, I wonder is this the time I will not be able to get it going? the only thing I've been able to do, and i'm not sure it helps but I do get going. is when it starts to stall (because it thinks either i) no one is in the seat or ii) the break is still on...as I move the arms in...I quickly put them back into neural position keeping the engine running - then move them back out very very slow...it seems to be a bit of a work-a-round. Oh, forgot to mention, let down the park break very very slow as well. so that's...park break down slow and arms out slow. and smooth for both. WHAT A PAIN!
    I worked on it again yesterday, taking the brake safety switch out and cleaning it. The contacts looked good. I did a continuity check on it and it seems to be switching off and on as it should. I have also noticed that sometimes if I just let the mower run for a few minutes after starting it up, it will work fine (sometimes). I'm beginning to suspect that the pressure switch on the pump might be the problem. Once it takes off, it will usually run fine the rest of the day. I might as well give up. This mower is an electrical nightmare.

  4. #14
    New Member
    Join Date
    May 2014
    Posts
    5
    Location
    Oxford, OH
    Tractor
    997Z

    Default Re: JD 997Z mower problem

    Quote Originally Posted by 9973720wb19 View Post
    since this is a JD forum, maybe you guys could help with my JD 997 Z mower. I have had an intermittent problem since day one...6/08. The safty feature will not allow the mower to start without park break on...fine. However, sometimes, after I start it (break on) then go to put the break down/off...the engine stalls. I took it to the dealer and they said they could not make this happen. I just did my spring tune and I had this issue one out of five fine starts.

    Any advise or information that would help in talking to my dealer?

    Thanks
    OK. Problem solved. I had to take it to the dealer to get it fixed. The problem was a faulty seat delay module located on the engine firewall.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Mowing JD 650 and a Sickle Bar Mower
    By WDP in forum John Deere Owning/Operating
    Replies: 4
    Last Post: 07-19-2009, 03:52 PM
  2. Mowing JD 350 sickle mower
    By laurencen in forum Kioti Owning/Operating
    Replies: 4
    Last Post: 07-16-2009, 03:58 PM
  3. JD 950 Power Steering/Hydaulics Problem
    By DJCohenour in forum Hydraulics
    Replies: 17
    Last Post: 04-19-2009, 07:47 PM
  4. Advice on connecting JD 513 mower
    By klby in forum Parts/Repairs
    Replies: 9
    Last Post: 03-17-2009, 09:40 AM
  5. Mowing JD Z445 Mower Help
    By Duckhnt in forum John Deere Owning/Operating
    Replies: 1
    Last Post: 09-30-2007, 09:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.