Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 31
  1. #21
    Gold Member Kiotikarl's Avatar
    Join Date
    Jan 2011
    Posts
    264
    Location
    Quebec Canada
    Tractor
    2010 Kioti ck30 gear

    Default Re: CK 30 Hydraulic problem

    Quote Originally Posted by DrewL View Post
    Check your diverter valve under right side fender.....make sure it is all the way open or shut (don't recall which way for BH use)
    The diverter valve is working correctly, have to place the A for the BH to work. Without the BH attached to the tractor, i have the same problem but with the FEL, and yesterday while moving the tractor no load in the bucket the power steering started to make the same growlling/vibrating noise.

  2. #22
    Gold Member
    Join Date
    Apr 2005
    Posts
    425
    Location
    Sandwich, MA
    Tractor
    Kioti

    Default Re: CK 30 Hydraulic problem

    ahhh, sounds like you getting closer to the culprit. Good luck
    Kioti CK30HST
    KL130 Loader
    KB2375 Backhoe
    LandPride FDR1572 mower
    5' King Kutter Brush mower
    5' King Kutter Box Blade
    5' York Rake
    King Kutter Middle Buster
    Post Hole Digger 12"
    6' rear blade
    3 Point log splitter
    Tooth bar
    Metric adjustable wrench
    Cup Holder
    Former '87 Grand National owner

  3. #23
    Gold Member Kiotikarl's Avatar
    Join Date
    Jan 2011
    Posts
    264
    Location
    Quebec Canada
    Tractor
    2010 Kioti ck30 gear

    Default Re: CK 30 Hydraulic problem

    Update; dealer road service mechanic supposed to come and check it out on thursday, and recall kioti after diagnostic.
    Anyone ever had an electric/hydraulic diverter valve istalled on the loader Having the mechanic at home, might as well get that installed, just in case i put a grapple on the bucket

  4. #24
    Elite Member dfkrug's Avatar
    Join Date
    Feb 2004
    Posts
    4,850
    Location
    NorCal
    Tractor
    05 Kioti CK30HST w/ Prairie Dog backhoe

    Default Re: CK 30 Hydraulic problem

    Quote Originally Posted by Kiotikarl View Post
    The diverter valve is working correctly, have to place the A for the BH to work. Without the BH attached to the tractor, i have the same problem but with the FEL, and yesterday while moving the tractor no load in the bucket the power steering started to make the same growlling/vibrating noise.
    From your descriptions, it sounds like you are not using a diverter for the
    backhoe; you are using a single AUX remote valve, set in the detented
    'A' position. That's how mine is powered, too.

    Sounds like you may have some problems with your PS flow divider or
    implement pump.

  5. #25
    Elite Member dfkrug's Avatar
    Join Date
    Feb 2004
    Posts
    4,850
    Location
    NorCal
    Tractor
    05 Kioti CK30HST w/ Prairie Dog backhoe

    Default Re: CK 30 Hydraulic problem

    Quote Originally Posted by Kiotikarl View Post
    Anyone ever had an electric/hydraulic diverter valve istalled on the loader
    I installed a 12V spool-type diverter on my FEL for 4n1 bkt use.

  6. #26
    Gold Member Kiotikarl's Avatar
    Join Date
    Jan 2011
    Posts
    264
    Location
    Quebec Canada
    Tractor
    2010 Kioti ck30 gear

    Default Re: CK 30 Hydraulic problem

    Update; Dealer called in, said they will replace the pump, it should resolve the problem, not sure bout that, dealer thinks its kinda weird.
    Anyways they will fix this and install the diverter on the loader at the same time. So this gives me time to build my grapple for the bucket

  7. #27
    Silver Member
    Advertiser
    MichiganIron's Avatar
    Join Date
    May 2008
    Posts
    529
    Location
    Central Michigan
    Tractor
    Full line of KIOTI Tractors, BEFCO and Worksaver Implements

    Default Re: CK 30 Hydraulic problem

    JUst worth mentioning...

    If the KIOTI rear selector valve that you use to run the backhoe isn't in nuetral without the backhoe plugged into the tractor (or an open center valved attachment) you will dead head the hydraulic system. This will lead to overheating the system, and cause a lot of the problems you have descibed in your thread.

    The rear selector valve must be returned to the neutral position whenever the backhoe is un-plugged. The tractor hydraulic system will whine, overheat, and loose power. Everntually you will start loosing power steering and Front Loader power as seals in the pump and valves begin to fail. It will eventually start to give off a "cooked" smell.

    Hope that's not what happened in your case.
    Michigan Iron and Equipment, LLC
    www.michironandequip.com

  8. #28
    Elite Member Mousefield's Avatar
    Join Date
    Aug 2008
    Posts
    2,520
    Location
    Qualicum Beach on Vancouver Island, BC. Canada
    Tractor
    2008 CK35 HST

    Default Re: CK 30 Hydraulic problem

    Quote Originally Posted by MichiganIron View Post
    JUst worth mentioning...

    If the KIOTI rear selector valve that you use to run the backhoe isn't in nuetral without the backhoe plugged into the tractor (or an open center valved attachment) you will dead head the hydraulic system. This will lead to overheating the system, and cause a lot of the problems you have descibed in your thread.

    The rear selector valve must be returned to the neutral position whenever the backhoe is un-plugged. The tractor hydraulic system will whine, overheat, and loose power. Everntually you will start loosing power steering and Front Loader power as seals in the pump and valves begin to fail. It will eventually start to give off a "cooked" smell.

    Hope that's not what happened in your case.
    I never met the dealer (Superior Tractor) I got my tractor from in Oregon, all done by e-mail and phone. During several phone calls he mention to me several times about the neutral position. The tractor came with a backhoe and the first time I took it off I called him to confirm I was doing everything right.
    Told me the same thing you posted MichiganIron.

  9. #29
    Gold Member Kiotikarl's Avatar
    Join Date
    Jan 2011
    Posts
    264
    Location
    Quebec Canada
    Tractor
    2010 Kioti ck30 gear

    Default Re: CK 30 Hydraulic problem

    Thanks guys, i know about to leave the remote rear valve in neutral when not having anything plugged in. The second remote returns to the neutral position by itself.
    What i do when using the rear remote (either with the winch or BH) turn the remote to A, use the implement, turn the remote to the neutral position, move the tractor, repeat if necessary

  10. #30
    Gold Member Kiotikarl's Avatar
    Join Date
    Jan 2011
    Posts
    264
    Location
    Quebec Canada
    Tractor
    2010 Kioti ck30 gear

    Default Re: CK 30 Hydraulic problem

    Update: As of today my tractor is now working good. Dealer road service did come and check it out, happened to be a bad relief valve. Anyhow i'm glad my tractor is fixed Also had this installed on my tractor, now just have to buy/make something to use it for
    Attached Thumbnails Attached Thumbnails -005-jpg  

Page 3 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. Ferguson TO30 Hydraulic Problem
    By juddsster in forum Hydraulics
    Replies: 14
    Last Post: 07-27-2012, 04:53 PM
  2. 3 pt hitch hydraulic problem
    By jimbull34 in forum Hydraulics
    Replies: 0
    Last Post: 10-02-2010, 12:20 PM
  3. Cat 262B Hydraulic Problem
    By rshackleford in forum Construction Equipment
    Replies: 2
    Last Post: 09-02-2010, 10:24 AM
  4. 3720 Hydraulic Problem
    By COLD_IRON in forum John Deere Owning/Operating
    Replies: 13
    Last Post: 01-14-2008, 11:27 PM
  5. DF-354 Dongfeng Tractor Hydraulic Problem
    By lp15404 in forum Chinese Tractors
    Replies: 60
    Last Post: 11-28-2006, 12:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.