Results 1 to 7 of 7
  1. #1
    Gold Member
    Join Date
    Jun 2004
    Posts
    311
    Location
    new hampshire
    Tractor
    Kioti DK55 Cab, 3 NHs (from 40-90HP)

    Default electrical issue?

    i noticed an intermittent electrical issue @ the 50 hr mark - now that the machine has 75 hrs on it, i'm going to tackle the source of the problem:

    one of my rear work lights stopped working. it works when the tractor is in reverse, but when you hit the switch only one light comes on. i'm guessing that the switch on the panel is the culprit here - any ideas of taking that apart to get to the wiring? ..it's not easy to determine by looking at it.

    this is likely unrelated, but sometimes i lose all preset radio stations - is it possible that these issues are related?

    i'll start pulling the machine apart later this week to see if i can track down the issue (frankly, i'm not concerned but i'd like to figure out what the issue is before the snow flies).

    any insight welcome!

    pf

    (dk55c)

  2. #2

    Join Date
    Jan 2004
    Posts
    5,974

    Default Re: electrical issue?

    Well, I'm not sure, but the losing presets sounds like an interruption of power to the radio.
    I have no idea how they routed all the wiring, but your dealer should have a service manual available with a wiring diagram. I would certainly let them take care of it since you're still under warranty.
    My dealer doesn't have one on his lot right now, so I can't look it over. Good luck. John

  3. #3
    Platinum Member
    Join Date
    Apr 2003
    Posts
    927
    Location
    Olathe, KS

    Default Re: electrical issue?

    I know that on some of the other DK Series, and im not sure about the DK55 ( I will have to go look), but the rear work light/ back up light has two bulbs in it. One for backup and one for reverse, sounds like the one worklight has burned out. As far as the radio, first thing i would check is ground wires, or battery connections to see if one needs to be tightened up.

  4. #4
    Veteran Member Steve_Miller's Avatar
    Join Date
    Mar 2004
    Posts
    1,220
    Location
    Nova Scotia, Canada
    Tractor
    2006 Kioti CK30HST

    Default Re: electrical issue?

    As far as the radio issue goes, the radio usually has two separate power sources. 1. The main source provides power to drive all functions. 2. The second source is strictly for retaining memory which keeps presets and the clock going. Reason being there is a lot less amp draw as to not drain the battery when tractor is not running. If this source was or happens to be on the same circuit as one or both rear worklights this would likely mean both problems are tied together. If not you have two problems. Possibly broken wire, a pinched wire or a bad connection somewhere. Let us know, you know how nosy we are. [img]/forums/images/graemlins/grin.gif[/img] [img]/forums/images/graemlins/grin.gif[/img] [img]/forums/images/graemlins/grin.gif[/img]

    Steve

  5. #5

    Join Date
    Jan 2004
    Posts
    5,974

    Default Re: electrical issue?

    </font><font color="blue" class="small">( Let us know, you know how nosy we are. )</font>
    LOL@Steve_Miller [img]/forums/images/graemlins/grin.gif[/img] John

  6. #6
    Gold Member
    Join Date
    Jun 2004
    Posts
    311
    Location
    new hampshire
    Tractor
    Kioti DK55 Cab, 3 NHs (from 40-90HP)

    Default Re: electrical issue?

    thanks for the input everyone - i'll see if i can get a copy of the wiring diagram from the dealer. in the meantime, i can check the bulb (heck, why didn't i bother to see if there were 2 bulbs in there!?).. but i agree about tearing it apart if its under warranty. i think it's a simple problem (things tend to get loose on tractors... i think this is my biggest learning experience so far).

    i'll keep the forum informed, i'll be "working from the farm" tomorrow (heck, i hope my boss isn't reading this forum!)

    pf

  7. #7
    Gold Member
    Join Date
    Jun 2004
    Posts
    311
    Location
    new hampshire
    Tractor
    Kioti DK55 Cab, 3 NHs (from 40-90HP)

    Default Re: electrical issue?

    hard to believe i waited a month to look @ this further (i'm evidently spending WAY too much time in the seat.. if there is such a thing!).

    took the rear light assembly apart last night - as pointed out, there are 2 bulbs (backup/work light). the work light is out - but it appears to be OK. the element is not (apparently) broken. got the wrong bulb from the dealer (next time i'll be smart enough to take the bulb with me!) - will put a meter on it this weekend to make sure it's getting power.

    more to follow..

    pf

    DK55c with 105 hrs!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2013 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.