Results 1 to 5 of 5
  1. #1

    Default G1900S idle

    The idle on my G1900S is not even. It wants to slow down and then come back to normal when it is sitting still. It's kind of like it is missing a beat at times.

    Any ideas of what to look for?

    Thanks
    Midlothian, TX

    '97 G1900S

  2. #2
    Epic Contributor jinman's Avatar
    Join Date
    Feb 2001
    Posts
    21,014
    Location
    Texas - Wise County - Sunset
    Tractor
    NHTC45D, NH LB75B, Ford Jubilee

    Default Re: G1900S idle

    When was the last time you changed both fuel filters (by the engine and the one behind the left wheel). Can you hear the electric lift pump running when you turn on the key but before you start the engine? Changing idle speeds is indicating a fuel delivery problem. It's either the lift pump and filters or the injector pump itself. How many hours do you have on it?
    Jim


  3. #3

    Default Re: G1900S idle

    Quote Originally Posted by jinman View Post
    When was the last time you changed both fuel filters (by the engine and the one behind the left wheel). Can you hear the electric lift pump running when you turn on the key but before you start the engine? Changing idle speeds is indicating a fuel delivery problem. It's either the lift pump and filters or the injector pump itself. How many hours do you have on it?
    I changed both fuel filters about 50 hours ago. The tractor has 422 total hours.

    I can hear the lift pump running when I turn the key on and the tractor starts fine. It's after it has been mowing for a while and I turn the blade off. This is when the idle is uneven.

    Of course here in North Texas with the drought I haven't been doing much mowing this summer. I was thinking it might be a fuel issue due to the inactivity?

    Your comments are appreciated.

    Dennis
    Midlothian, TX

    '97 G1900S

  4. #4
    Silver Member
    Join Date
    Jan 2008
    Posts
    204
    Location
    Jefferson County, WV
    Tractor
    2003 Kubota B7800 (new to me @ 435 hours

    Default Re: G1900S idle

    I had a similar issue with my new to me G1900...dealer suggested some diesel fuel treatment and that caused the problem to go away.

    Hopefully it is that simple for you.
    B7800 (new to me 2/6/8 @435 hours), 402 FEL, Woods GB60, RB72, LR72, PHD, Chain forks, 60 MMM

    G1900 (new to me at 1100 hours), 60 inch deck, snow blade, chains

  5. #5
    New Member
    Join Date
    Jun 2005
    Posts
    2

    Default Re: G1900S idle

    Does anyone here have the manual for the G1900s? I inherited one without a manual and it doesn't run (yet). It would help to have access to the manual. For example, I didn't know it had TWO fuel filters (thanks jinman)... I don't want to invest too much money into it until I find out if it will run.

Similar Threads

  1. Kawi Mule Idle Issues
    By robertwhite in forum ATVs & Utility Vehicles
    Replies: 4
    Last Post: 10-26-2009, 01:02 AM
  2. Idle level question on LT1045
    By lexus114 in forum Cub Cadet L&G
    Replies: 2
    Last Post: 08-26-2008, 09:32 AM
  3. To idle to not to idle
    By BlackRaptor in forum John Deere Owning/Operating
    Replies: 16
    Last Post: 06-02-2008, 02:58 AM
  4. Idle Surge... High Idle... Eratic Idle
    By Reaney in NH in forum Chinese Tractors
    Replies: 7
    Last Post: 08-11-2007, 10:31 PM
  5. 2004 250 Honda Recon wont Idle
    By Barnboy in forum ATVs & Utility Vehicles
    Replies: 2
    Last Post: 02-26-2006, 08:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.