Results 1 to 2 of 2
  1. #1
    Gold Member swampvol's Avatar
    Join Date
    Mar 2007
    Posts
    390
    Location
    SC
    Tractor
    Kubota l3400HST TLB

    Default Help!!

    I just changed the hydro fluid, for the 2nd time, and am having some problems.

    I changed it at 50hrs, no problems, the only difference now (200 hrs) is while changing I replaced a quick-attached that had been leaking ever since I had the backhoe installed..

    I can go forward and reverse, curl the bucket and lift and lower the fel while curling, but I can't lower or raise the 3-point, nor the fel straight up or down.

    I'd guess that I have air in the lines, but working the fel and 3-point for the last 30 minutes isn't working.

    L3400 hst.

    Any help would be much appreciated.
    "I drink beer to make other people interesting"

  2. #2
    Silver Member aggiehortguy91's Avatar
    Join Date
    Feb 2009
    Posts
    120
    Location
    Jupiter, FL
    Tractor
    '01 BX2200

    Default Re: Help!!

    My guess is that new quick connect didn't seat properly when you reconnected it or it is not the correct fitting to match what you already have. If you only did those two things, that is atleast where I would start. It should only take one cycle to bleed any air out of the lines.
    BX2200 w/ turf tires, LA211 loader, 4' box blade, and 60" MMM

    Shh! Don't tell her she's a little tractor.....she doesn't know

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2013 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.