Results 1 to 8 of 8
  1. #1

    Default Spraying UDT From Back

    I was using my BX 1860 yesterday with the front end loader and a weight box when it suddenly started spraying lots of UDT Fluid from the back. The fluid is coming from where the U shaped tube coming from the three point control valve connects. spraying out around the flared fitting on the left side. The fitting was tight, I removed it and inspected it and reinstalled, it is still leaking. seeping out at idle and spraying when the control valve is used. I can't find a split or crack in the fitting or tube. any ideas what is happening?

  2. #2
    Platinum Member
    Join Date
    Mar 2003
    Posts
    927
    Location
    Maine
    Tractor
    Kubota B2620

    Default Re: Spraying UDT From Back

    I could be a cracked fitting that only shows when under pressure. Speaking of that, watch out for the spray....at high pressure it can cut your finger quite badly

  3. #3

    Default

    went to the nearby kubota dealer, didn't have the part, so he made me a hydraulic hose to fit. put that on, leak stopped, topped off the UDI hand thought I was all set. now I have now hydraulic power to the 3 point hitch or loader. The tractor runs fine and goes forward and backwards, even have power steering. Does something have to be bled? Do I have something else wrong?

  4. #4

    Default

    [QUOTE="rick480;3310799"]went to the nearby kubota dealer, didn't have the part, so he made me a hydraulic hose to fit. put that on, leak stopped, topped off the UDI hand thought I was all set

  5. #5

    Default

    [QUOTE="rick480;3310799"]went to the nearby kubota dealer, didn't have the part, so he made me a hydraulic hose to fit. put that on, leak stopped, topped off the UDI hand thought I was all set. Unfortunately now I have no hydraulic power at the 3 point hitch or Loader. The tractor runs and goes forward and backwards fine, even has power steering. Does something have to be bled? Do I have something else wrong?

  6. #6

    Default

    Quote Originally Posted by rick480 View Post
    went to the nearby kubota dealer, didn't have the part, so he made me a hydraulic hose to fit. put that on, leak stopped, topped off the UDI hand thought I was all set
    Now I have no hydraulic power to the 3 point or the loader, the tractor runs and goes forward and backwards fine. Even has power steering. does something have to be bled? do I have something else wrong?

  7. #7
    Platinum Member
    Join Date
    Mar 2003
    Posts
    927
    Location
    Maine
    Tractor
    Kubota B2620

    Default Re: Spraying UDT From Back

    try turning the steering wheel side to side. I read somewhere that that will help to purge air in the system

  8. #8

    Default

    Turns out that the hose they made me was defective, there was no opening in one of the fittings, explains why I had no hydraulics.

Similar Threads

  1. Yard Spraying
    By Achilles in forum Attachments
    Replies: 10
    Last Post: 01-31-2009, 09:56 PM
  2. Spraying 2-4D
    By Eric_Phillips in forum Projects
    Replies: 14
    Last Post: 08-07-2008, 02:05 PM
  3. tree spraying
    By oldhippy in forum Attachments
    Replies: 4
    Last Post: 05-07-2006, 07:28 AM
  4. Spraying
    By Eric_Phillips in forum Attachments
    Replies: 8
    Last Post: 09-07-2005, 06:03 PM
  5. Should I add soap to 2,4D for spraying
    By Von in forum Rural Living
    Replies: 1
    Last Post: 06-29-2002, 12:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.