Results 1 to 3 of 3
  1. #1

    Default Lost Power Steering

    Hi All,

    I am new to this very informative site and hope that you may be able to help me understand my problem.

    At work, we have a M5030 (11 years old) with a loader. On Monday, hydraulic fluid filled the crankcase to the point of overflow. Suspecting a faulty hydraulic pump, I called the dealer and they advised that a seal kit would cost 20 - 30 dollars or if it was a bad pump, it would cost around 1000 dollars to replace it. We decided to try and replace the seals on our own to see if that would correct the problem. There was one demolished internal seal and the seal that is on the outside cover around the shaft was torn allowing the fluid to get to the engine. After replacing the seals, we bolted the pump back on and cranked the tractor. The loader worked flawlessly, but now it has no steering. In fact, the steering wheel will turn with no friction and has no stopping point.

    It appears that the pump is a two section unit, one controlling the loader and 3pt. hitch and another that controls the steering. I took the pump apart again, but I don't undersand how the fluid gets to the section of the pump that powers the steering.

    I know just enough about hydraulics to get myself in trouble and would appreciate any feedback that you may have. Worst case, I will take it in next week, but I hate to be stumped. Thanks for your advice.


  2. #2
    Veteran Member
    Join Date
    Sep 2004
    Posts
    2,409
    Location
    Kansas, Butler county, Just east of DooDah
    Tractor
    Kubota L4200 GSTCA

    Default Re: Lost Power Steering

    Welcome to TBN…
    It is my guess you need to bleed the air from the steering circuit… The steering wheel has no center or stops… it is actually a pump, and when fed with pressurized oil will easily direct that high pressure oil to the steering cylinder… bleed the steering system and you will have no problems…. KennyV.

  3. #3

    Default Re: Lost Power Steering

    Thanks KennyV,

    That is what I thought and tried. Maybe, I didn't give it enough time. We tried to cycle the steering several times with the front wheels raised. We disconnected the lines at the steering cylinder and got no flow. Then, we disconnected the line at the pump, which appears to feed the steering and no fluid was leaving the pump with the tractor running. That is the puzzling part. It seems that the pump should be pumping a good amount with the line completely disconnected. The pump also got pretty warm to touch. I don't know if that is normal or not.

    Anyway, thanks for the welcome and the advice. We will try again on Monday.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.