Results 1 to 4 of 4
  1. #1
    Gold Member
    Join Date
    Mar 2002
    Posts
    486
    Location
    So MD
    Tractor
    Yanmar FX24D replaced with Massey GC2400

    Default GC2400 Tach Problem

    My tach stopped working today while mowing. I haven't yet pulled the cable. Anyone else had any problems

  2. #2
    Elite Member Don87's Avatar
    Join Date
    May 2010
    Posts
    4,226
    Location
    SW Pa.
    Tractor
    Massey Ferguson GC2400

    Default Re: GC2400 Tach Problem

    Quote Originally Posted by blackd View Post
    My tach stopped working today while mowing. I haven't yet pulled the cable. Anyone else had any problems
    Several people have reported broken cables.
    Don

    MF GC2400, FEL, 60in.MMM, 5ft. Cultivator, Single Bottom Plow, Bush Hog RTC48 tiller, MF 2360 front mount snowblower, 5ft backblade. BXpanded Piranha toothbar.

  3. #3
    Veteran Member Wacky's Avatar
    Join Date
    Apr 2010
    Posts
    1,077
    Location
    West Virginia
    Tractor
    2010 GC2610

    Default Re: GC2400 Tach Problem

    Quote Originally Posted by blackd View Post
    My tach stopped working today while mowing. I haven't yet pulled the cable. Anyone else had any problems
    Like Don said. When you replace it, drip some kind of lube down the cable every so often to protect the new one. I have been using 2-in-1.
    2010 MF GC2610--MF60"MMM--King Kutter XB 4' rotary cutter-- 4' King Kutter XB boxblade-- Ratchet Rake-- Check that parking brake

  4. #4
    Gold Member
    Join Date
    Mar 2002
    Posts
    486
    Location
    So MD
    Tractor
    Yanmar FX24D replaced with Massey GC2400

    Default Re: GC2400 Tach Problem

    Yup! Broken cable. Now to find the lower fitting to remove and replace.

Similar Threads

  1. Boomer Problems
    By froggy in forum New Holland Owning/Operating
    Replies: 29
    Last Post: 03-21-2014, 02:29 PM
  2. B2400 starting problem finally solved
    By victor43 in forum Kubota Owning/Operating
    Replies: 47
    Last Post: 08-30-2013, 01:38 PM
  3. Power Steering Problem Not Solved
    By Alan L. in forum Kubota Owning/Operating
    Replies: 87
    Last Post: 03-31-2011, 06:35 PM
  4. KL130 on a CK30 Problem
    By tierbb in forum Kioti Owning/Operating
    Replies: 74
    Last Post: 11-20-2007, 03:06 PM
  5. B2400 Starting Problem
    By victor42 in forum Kubota Owning/Operating
    Replies: 7
    Last Post: 06-03-2004, 07:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.