Results 1 to 8 of 8
  1. #1
    New Member
    Join Date
    Apr 2014
    Posts
    4
    Location
    Traphill,NC
    Tractor
    mf135

    Default mf135 hyd lift not working properly

    have changed fluid and cleaned filter. when I hooked up a disc it worked good, did not leak down. when I changed to a bush hog it will not lift the bush hog. with tractor running and lift lever in up position I can lift the bush hog with little effort by hand but when I turn loose it goes back down. any suggestions as what to do next will be appreciated. thank you in advance.

  2. #2
    Silver Member Trey318's Avatar
    Join Date
    Nov 2013
    Posts
    118
    Location
    Jesup Ga
    Tractor
    1972 John Deere 2630 1987 John Deere 4850 Case 7250 Ford 3000 1956 John Deere 520 1952 John Deere M 1980 John Deere 314 1952 John Deere 60 1992 John Deere 318 2013 John Deere 5083e

    Default

    I'm not trying to make you feel stupid but is your draft control all the way up? I know I've made the mistake of grabbing the draft more times than I can count

  3. #3
    New Member
    Join Date
    Apr 2014
    Posts
    4
    Location
    Traphill,NC
    Tractor
    mf135

    Default Re: mf135 hyd lift not working properly

    I appreciate your reply, the draft control lever is all the way up. that part of the lift appears to e working properly. thanks

  4. #4
    Silver Member
    Join Date
    Jul 2013
    Posts
    226
    Location
    nz
    Tractor
    MF5465

    Default Re: mf135 hyd lift not working properly

    Just double checking, are your discs drawbar type or 3ph type (you are ambiguous on that point)?
    Did the 3ph lift trouble develop over time, or just strike when you put the brush hog on?
    Is there a section of the lever controls that says "Preassure Control"? It almost sounds like you are trying to lift on preassure control and not position control

  5. #5
    New Member
    Join Date
    Apr 2014
    Posts
    4
    Location
    Traphill,NC
    Tractor
    mf135

    Default Re: mf135 hyd lift not working properly

    Quote Originally Posted by redman135 View Post
    Just double checking, are your discs drawbar type or 3ph type (you are ambiguous on that point)?
    Did the 3ph lift trouble develop over time, or just strike when you put the brush hog on?
    Is there a section of the lever controls that says "Preassure Control"? It almost sounds like you are trying to lift on preassure control and not position control
    I appreciate your reply. The disk is 3 point hitch. When I started using the tractor this spring the lift was slow. I then changed the fluid and cleaned the filer. With the disk it worked fine but it did not want to lift the bush hog. It does no have any pressure control on the outside. It may have one internally. Thank you

  6. #6
    Silver Member
    Join Date
    Jul 2013
    Posts
    226
    Location
    nz
    Tractor
    MF5465

    Default Re: mf135 hyd lift not working properly

    There is another possibility, and that is worn draught control linkages (internal). On the tractor, look below the top link, you will see a long pin going throgh 3 supports. Fit a chain (top link won't fit) or wire rope in place of the top link, and try lifting the brush hog. If it lifts easily then you have worn draught control linkages. If it doesn't lift then I am stumped.
    I had a 135 with worn draught control linkages and had bypassed the top link .I could lift the front wheels of the ground easily. Using the top link position I had zero lift as you describe.
    Due to the cost of repair I opted for the bypassed top link. It worked another 16 years before being sold "as is" about 2010.

  7. #7
    New Member
    Join Date
    Apr 2014
    Posts
    4
    Location
    Traphill,NC
    Tractor
    mf135

    Default Re: mf135 hyd lift not working properly

    Quote Originally Posted by redman135 View Post
    There is another possibility, and that is worn draught control linkages (internal). On the tractor, look below the top link, you will see a long pin going throgh 3 supports. Fit a chain (top link won't fit) or wire rope in place of the top link, and try lifting the brush hog. If it lifts easily then you have worn draught control linkages. If it doesn't lift then I am stumped.
    I had a 135 with worn draught control linkages and had bypassed the top link .I could lift the front wheels of the ground easily. Using the top link position I had zero lift as you describe.
    Due to the cost of repair I opted for the bypassed top link. It worked another 16 years before being sold "as is" about 2010.
    I appreciate your information. I was able to adjust the pressure on the draft control spring and put mine back to working. There is a nut under the rubber boot at the top link yoke. I thightend it about three quarter to one turn and am now back to working fine. Again I appreciate all help. thanks again.

  8. #8
    Silver Member
    Join Date
    Jul 2013
    Posts
    226
    Location
    nz
    Tractor
    MF5465

    Default Re: mf135 hyd lift not working properly

    Good one, a simple fix to a possibly expensive problem puts a shine on the day.

Similar Threads

  1. IH 260A hydraulics not working properly
    By mprice214 in forum Hydraulics
    Replies: 0
    Last Post: 01-04-2014, 10:19 PM
  2. Replies: 0
    Last Post: 11-12-2013, 09:59 AM
  3. Are these brakes working properly?
    By MillWeld in forum Trailers & Transportation
    Replies: 19
    Last Post: 12-31-2012, 04:40 PM
  4. Hydraulics not working properly
    By bigl in forum Hydraulics
    Replies: 1
    Last Post: 09-07-2012, 03:28 PM
  5. Backhoe Backhoe working properly?
    By B7500 in forum Owning/Operating
    Replies: 6
    Last Post: 09-24-2002, 09:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.