Results 1 to 3 of 3
  1. #1

    Join Date
    Feb 2005
    Posts
    6
    Location
    Illinois

    Default Satoh Buck

    I have a 1983 Satoh Buck and while I was using my 3pt. back blade I lost the neutral position on my hydraulic lift. Everything still works fine other than the implement will not stay in the raised position. It raises and lowers fine but ya have to hold the hyd. lift lever in the neutral position by hand or strap it down. I was going to take the trans. cover off but I wanted to know what I was looking for before I did this. Any help would be appr. I have 2500 hours on this tractor and this is the first major problem I have had with it. Thanks

  2. #2
    Veteran Member
    Join Date
    Sep 2002
    Posts
    1,499
    Location
    Mt. Ulla, NC
    Tractor
    Satoh S-470D, Mitubishi FD 1450D

    Default Re: Satoh Buck

    I have a Buck also and have not had this problem. If Bill or Len don't answer you might post on the Mitsubishi club forum on Yahoo. I saw on another post you got a front blade with yours. Do you still have it?

  3. #3
    Veteran Member
    Join Date
    Apr 2000
    Posts
    1,595
    Location
    Dixon, Il

    Default Re: Satoh Buck

    You must have a problem in your control valve. You have to remove the lift housing to access it. Parts are not available for the control valve. If it is warn it has to be replaced as a unit. I can supply you with a new or used valve.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.