Results 1 to 7 of 7
  1. #1
    New Member
    Join Date
    Jul 2014
    Posts
    3
    Location
    east central IN
    Tractor
    Ford 5200, Ford 7200, Ford 8700, Ford 641

    Default Ford 5200 slow hydraulics

    Have a Ford 5200 that came from the factory without auxiliary hydraulics. Previses owner added a Cross single DA remote. Changed remote 2 years ago. The 3 point lift works fine without any trouble what so ever. The problem is the auxiliary keeps getting slower and slower and to the point it won't lift some equipment. Any ideals?

  2. #2
    Platinum Member
    Join Date
    Jan 2012
    Posts
    516
    Location
    California
    Tractor
    Ford 7710, Ford 550, Ford 1910, Ford 4430, KD Forklift, Ford LGT17H, New Holland L255 Skidsteer

    Default

    Can it be assumed that this problem is on more than one piece of equipment? Does the Cross valve have a relief on it? What sort of things are you lifting with the 3pt? How heavy?

  3. #3
    New Member
    Join Date
    Jul 2014
    Posts
    3
    Location
    east central IN
    Tractor
    Ford 5200, Ford 7200, Ford 8700, Ford 641

    Default Re: Ford 5200 slow hydraulics

    I'm not sure if it has a relief valve or not.As far as the 3 point, I'm not sure the weight of a 6 row Buffalo cultivator, but lifts it no problem. Makes the front end lite.

  4. #4
    Platinum Member
    Join Date
    Jan 2012
    Posts
    516
    Location
    California
    Tractor
    Ford 7710, Ford 550, Ford 1910, Ford 4430, KD Forklift, Ford LGT17H, New Holland L255 Skidsteer

    Default

    One more question. It sounds like you may have enough hydraulic pressure. Are you using different implements on the remote that you see this problem or just one implement?

  5. #5
    New Member
    Join Date
    Jul 2014
    Posts
    3
    Location
    east central IN
    Tractor
    Ford 5200, Ford 7200, Ford 8700, Ford 641

    Default Re: Ford 5200 slow hydraulics

    Quote Originally Posted by TractorTech View Post
    One more question. It sounds like you may have enough hydraulic pressure. Are you using different implements on the remote that you see this problem or just one implement?
    Haybine, planter, disc , but did lift plow ok.

  6. #6
    Platinum Member
    Join Date
    Jan 2012
    Posts
    516
    Location
    California
    Tractor
    Ford 7710, Ford 550, Ford 1910, Ford 4430, KD Forklift, Ford LGT17H, New Holland L255 Skidsteer

    Default

    Is the plow a 2 point with lift assist or 3 point mounted?
    The haybine used for lift and or offset?
    What size disc?
    Easiest way to check what might be culprit, plug a 5000 psi gauge in remote outlet. See if it is in 2500 psi range +/- 200 psi.

  7. #7
    Silver Member
    Join Date
    May 2014
    Posts
    179
    Location
    Paarl

    Default

    Internal filter cloged ?

Similar Threads

  1. Ford 3000 Very Slow Hydraulics
    By HelpingAFriend in forum New Holland Ag Tractors
    Replies: 10
    Last Post: 04-21-2015, 11:14 PM
  2. Ford 640 Hydraulics slow
    By lawdealer in forum Hydraulics
    Replies: 2
    Last Post: 12-03-2011, 06:46 PM
  3. Ford 3000 very slow hydraulics
    By Mbbuk in forum Hydraulics
    Replies: 5
    Last Post: 06-10-2011, 01:02 PM
  4. Ford 1710 rear hydraulics slow/not working
    By Minorhero in forum Hydraulics
    Replies: 26
    Last Post: 03-27-2010, 11:56 PM
  5. Slow Hydraulics
    By Anonymous Poster in forum Kubota Owning/Operating
    Replies: 4
    Last Post: 12-16-2001, 06:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.