Results 1 to 3 of 3
  1. #1

    Join Date
    Jan 2002
    Onaway, MI
    John Deere 730 General Pupose Diesel & NH TN65D

    Default Anyone have these problems?

    I've got a NH TN65D. Been a great tractor so far but I have a couple of minor nagging problems:
    1. The 4WD engaged icon light on the dash works intermittently (sometimes it lights up and sometimes it doesn't) when I have the tractor in 4WD. It's not a loose bulb or wire I can see. Maybe a bad switch?
    2. Cat II bushing would fall out of left draft arm with retaining pin still in place.
    3. Instrument panel fogs up.
    4. The small retaining fitting on the 3 pt control lever linkage pops off in cold weather when using the 3 pt hitch. (retainer is a thin clip I think NH could beef up)

    I bought the tractor last year. Had the dealer out for the 50 hour oil/filter change and asked them to look at the problems.
    The dealer replaced the whole end on the left draft arm, put a new retainer fitting on the 3 point lever linkage, but is puzzled over the icon light and the fogging instrument panel. Any insight from TN owners would be appreciated.

  2. #2
    Super Member Robert_in_NY's Avatar
    Join Date
    Aug 2001
    Silver Creek, NY
    Case-IH Farmall 45A, Kubota M8540 Narrow, New Holland TN 65, Bobcat 331, Ford 1920, 1952 John Deere M, Allis Chalmers B, Bombardier Traxter XT, Massey Harris 81RC and a John Deere 3300 combine, Cub Cadet GT1554

    Default Re: Anyone have these problems?

    I had a slight bit of moisture fog the lower center portion of mine but I never worried about it because it didn't block my view of the gauges. As for your light, I have no clue. I don't have that light on mine since I lack a cab but I did have a problem with the pto switch not disengaging which kept that light on in the dash, the pto disengaged but the light didn't? Only happened a couple times in one day and never since. Never had any of the other problems you had either though.

  3. #3
    Old Timer Soundguy's Avatar
    Join Date
    Mar 2002
    Central florida
    ym1700, NH7610S, Ford 8N, 2N, NAA, 660, 850 x2, 541, 950, 941D, 951, 2000, 3000, 4000, 4600, 5000, 740, IH 'C' 'H', CUB, John Deere 'B', allis 'G', case VAC

    Default Re: Anyone have these problems?

    Anyone ever notice if any non-oem gauges that are backlit ever fog up? Wonder if maybee NH shouldn't install backlit gauges.... just another few watts of power... maybee it would help solve the problem of the fogged gauges.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
© 2016 TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.