Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17
  1. #11
    Elite Member JC-jetro's Avatar
    Join Date
    Jul 2006
    Posts
    3,284
    Location
    Kansas
    Tractor
    Ford 1700, Kubota MX-4700

    Default Re: Ford 1700 No Hydraulics

    Quote Originally Posted by oldford1700 View Post
    When I went to fix it, it miraculaously was working, BUT the filter was filthy so I'm guessing the problem was caused by fluid flow. Changed fluid, cleaned filter and all O rings and now works great - nice and smooth and more responsive than before. Always happy with simple fixes. Thanks for the all the info.

    Success at last, anytime you find that it is not the Hyd pump for the old rig is good news.

    JC,
    Ford 1700, 2wd.
    Kubota MX-4700DT, Gear transmission with LA 884 loader, Q/A and HD bucket.
    60" Woods Rotary Cutter, home made (3-pt boom and a Row Hipper) ,King Kutter( 5 ft Tiller,Middle Buster,Single Row Cultivator,Carry-all, 5 ft blade, 6 ft Landscaping Rake ,30" Dirt Scoop and a 4'x4' Drag Harrow)

  2. #12
    New Member
    Join Date
    Jul 2017
    Posts
    1
    Location
    Wolfe City
    Tractor
    Ford 1910

    Default Re: Ford 1700 No Hydraulics

    I know this is an older post but is there a way to get the photos to show again as I am having the same problem with my 1910?

  3. #13
    Platinum Member
    Join Date
    Sep 2012
    Posts
    912
    Location
    MA
    Tractor
    Ford 1920

    Default Re: Ford 1700 No Hydraulics

    He most likely had a clogged screen. It's a metal screen that looks like a filter, it it locate on the back axle on the right hand side of a 1700. Not sure if the 1910's have a screen or if they changed to a real filter. I know my 1920 has a real filter. Filter is much easier to change than to clean the screen. I had a 1700 and my screen would clog about one every year and a half.

  4. #14
    Elite Member JC-jetro's Avatar
    Join Date
    Jul 2006
    Posts
    3,284
    Location
    Kansas
    Tractor
    Ford 1700, Kubota MX-4700

    Default Re: Ford 1700 No Hydraulics

    I lost a ton of pics when my picture posting site changed it's policy.in retrospect I wished ti have uploaded then to TBN. I will try to see if I can mange to change it's setting.

    JC
    Ford 1700, 2wd.
    Kubota MX-4700DT, Gear transmission with LA 884 loader, Q/A and HD bucket.
    60" Woods Rotary Cutter, home made (3-pt boom and a Row Hipper) ,King Kutter( 5 ft Tiller,Middle Buster,Single Row Cultivator,Carry-all, 5 ft blade, 6 ft Landscaping Rake ,30" Dirt Scoop and a 4'x4' Drag Harrow)

  5. #15
    Elite Member JC-jetro's Avatar
    Join Date
    Jul 2006
    Posts
    3,284
    Location
    Kansas
    Tractor
    Ford 1700, Kubota MX-4700

    Default Re: Ford 1700 No Hydraulics

    Folks,

    I can not do the 3rd party hosting unless I pay quite a bot and that is not sustainable. However, you can right click and open the image in the new tab, I have made those pictures public.

    Jc,
    Ford 1700, 2wd.
    Kubota MX-4700DT, Gear transmission with LA 884 loader, Q/A and HD bucket.
    60" Woods Rotary Cutter, home made (3-pt boom and a Row Hipper) ,King Kutter( 5 ft Tiller,Middle Buster,Single Row Cultivator,Carry-all, 5 ft blade, 6 ft Landscaping Rake ,30" Dirt Scoop and a 4'x4' Drag Harrow)

  6. #16
    New Member
    Join Date
    May 2017
    Posts
    1
    Location
    Blue Mounds, WI
    Tractor
    Ford 1700

    Default Re: Ford 1700 No Hydraulics

    JC,
    Another 1700 with hydraulic problems. I cleaned the filter, which made things work ok for a bit. Then it went slow, 3ph drops when the engine is off, now no hydraulics at all. I assume I've got a bad seal in the 3ph piston. ?? Maybe more.
    I'm trying to read over your posts, but I'm not able to figure out how to see the photos. When I right click, it takes me to ImageShack, but no pictures. Any ideas?
    Thank you,
    Paul

  7. #17
    Elite Member JC-jetro's Avatar
    Join Date
    Jul 2006
    Posts
    3,284
    Location
    Kansas
    Tractor
    Ford 1700, Kubota MX-4700

    Default Re: Ford 1700 No Hydraulics

    Paul,

    I had a lot pf pictures here but I used a site that hosted my pictures. They have changed policy and wanted bunch of money to maintain the pictures, so basically I lost the ability to post. I think they allowed a bout 1000 pics and they are hit and miss as far showing up in the post. Since then I have another provided that allows free posting but it will be such a time consuming endeavor for me to go to all my post and remember what picture I had and try to re-post them, that just take tremendous amount will and time. I think your issue might be seal on the lift cylinder that is easy to change and costs you very little. You can pm me with exactly what pics you need and I will send it your way.

    JC,

    Quote Originally Posted by undy View Post
    JC,
    Another 1700 with hydraulic problems. I cleaned the filter, which made things work ok for a bit. Then it went slow, 3ph drops when the engine is off, now no hydraulics at all. I assume I've got a bad seal in the 3ph piston. ?? Maybe more.
    I'm trying to read over your posts, but I'm not able to figure out how to see the photos. When I right click, it takes me to ImageShack, but no pictures. Any ideas?
    Thank you,
    Paul
    Ford 1700, 2wd.
    Kubota MX-4700DT, Gear transmission with LA 884 loader, Q/A and HD bucket.
    60" Woods Rotary Cutter, home made (3-pt boom and a Row Hipper) ,King Kutter( 5 ft Tiller,Middle Buster,Single Row Cultivator,Carry-all, 5 ft blade, 6 ft Landscaping Rake ,30" Dirt Scoop and a 4'x4' Drag Harrow)

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Ford 1700 and Ford 1710 parts machines - now what?
    By bspeedy in forum New Holland Buying/Pricing
    Replies: 11
    Last Post: 06-04-2015, 12:47 PM
  2. Ford 1700 auxiliary hydraulics
    By nsmithnd in forum New Holland Owning/Operating
    Replies: 9
    Last Post: 04-27-2013, 12:35 AM
  3. Ford 1700 Hydraulics
    By BRANTLEYASSOC in forum Hydraulics
    Replies: 6
    Last Post: 04-12-2011, 05:08 PM
  4. Ford Hydraulics on a 1700
    By FIRE1388 in forum New Holland Owning/Operating
    Replies: 8
    Last Post: 03-26-2009, 10:53 PM
  5. Ford 1700
    By b33b in forum New Holland Buying/Pricing
    Replies: 4
    Last Post: 10-03-2006, 06:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2017 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.