Results 1 to 6 of 6
  1. #1
    Member
    Join Date
    Aug 2012
    Posts
    45
    Location
    Chesapeake, VA
    Tractor
    Ford

    Default 73 Ford 2000 Replaced cluth, now hydraulics does not work HELPPPPPP!!

    Well I have replaced the cluth etc on my ford 2000. Runs great! Now the hydraulics are not working. The 3-point lift does not function at all. I bled the hydraulic pump and it did not seem to have any pressure behind it. The hydraulic fluid was flowing out, however, it seemed as though there was no pressure at all. I sure could use some help.

  2. #2
    Epic Contributor Soundguy's Avatar
    Join Date
    Mar 2002
    Posts
    46,366
    Location
    Central florida
    Tractor
    ym1700, NH7610S, Ford 8N, 2N, NAA, 660, 850 x2, 541, 950, 951, 2000, 3000, 4000, 4600, 5000, 740, IH 'C' 'H', CUB, John Deere 'B', allis 'G', case VAC

    Default Re: 73 Ford 2000 Replaced cluth, now hydraulics does not work HELPPPPPP!!

    ok.. first thing to check ( and you may have done this ) is to see if the pump is making any flow. there will be a plug ont he pump you can pull.. should make decent flow.

    if so.. then move up to the hyd top cover.. there will be a 3x5 option plat ethere with a plug in it. put a hyd gauge in there capable of 3000 psi, then chain the 3pt arms to the axles and exercise the lift... should show relief pressure of around 2250-2500..

    if you have a remote valve there.. make sure it is not kicked open.

    in nada.. and you have flow.. next thing is to check the unloader vlave.. it could be stuckk.. though i'd play withthe draft control FIRST and see what happens.

    if NO flow, I'd check the suction line on the pump.. it may be loose.. and sucking air. if it is.. it needs to be corrected.. it will help cause cavitation.. could also pressurize the rear sump with a rubber tipped blowgun a bit and see if the system primes.

  3. #3
    Member
    Join Date
    Aug 2012
    Posts
    45
    Location
    Chesapeake, VA
    Tractor
    Ford

    Default Re: 73 Ford 2000 Replaced cluth, now hydraulics does not work HELPPPPPP!!

    When I replaced the clutch, I removed the two lines from the hydr. pump, do you think that the o-ring on the suction side could be the problem? I pulled the old o-ring out and it is still pliable yet, it seems to be "flat" on the inside. Should I replace both of the o-rings on the suction line? (one on either end) I checked the fluid level, it is fine and the hydraulics were working when I started the clutch replacement.

  4. #4
    Epic Contributor Soundguy's Avatar
    Join Date
    Mar 2002
    Posts
    46,366
    Location
    Central florida
    Tractor
    ym1700, NH7610S, Ford 8N, 2N, NAA, 660, 850 x2, 541, 950, 951, 2000, 3000, 4000, 4600, 5000, 740, IH 'C' 'H', CUB, John Deere 'B', allis 'G', case VAC

    Default Re: 73 Ford 2000 Replaced cluth, now hydraulics does not work HELPPPPPP!!

    i never would re-use an oring.... just asking for trouble...

  5. #5
    Member
    Join Date
    Aug 2012
    Posts
    45
    Location
    Chesapeake, VA
    Tractor
    Ford

    Default Re: 73 Ford 2000 Replaced cluth, now hydraulics does not work HELPPPPPP!!

    Well, that was the problem! I had help when I replaced the clutch and when reassembling the hydraulics, the o-rings were over-looked. This just shows that a .45cent o-ring can cause a huge headache. I replaced the o-rings and the hydr. pump picked up a prime and the 3-point is lifting like a champ. I bled the pump and it is better than before.

  6. #6
    Epic Contributor Soundguy's Avatar
    Join Date
    Mar 2002
    Posts
    46,366
    Location
    Central florida
    Tractor
    ym1700, NH7610S, Ford 8N, 2N, NAA, 660, 850 x2, 541, 950, 951, 2000, 3000, 4000, 4600, 5000, 740, IH 'C' 'H', CUB, John Deere 'B', allis 'G', case VAC

    Default Re: 73 Ford 2000 Replaced cluth, now hydraulics does not work HELPPPPPP!!

    glad to hear you got it.

Similar Threads

  1. 1975 Ford 2000 Hydraulics Bleeding
    By 99FordStang in forum New Holland Owning/Operating
    Replies: 1
    Last Post: 12-13-2012, 08:57 PM
  2. Ford 2000 3cyl gas--Hydraulics
    By ron65729 in forum New Holland Owning/Operating
    Replies: 5
    Last Post: 07-30-2012, 11:00 AM
  3. !972 Ford 2000 Hydraulics
    By myford001 in forum Hydraulics
    Replies: 5
    Last Post: 04-27-2012, 01:11 PM
  4. Ford 2000 Hydraulics/Rear End/Transmission
    By Oswego Bill in forum Hydraulics
    Replies: 0
    Last Post: 02-21-2011, 04:15 PM
  5. ford 2000 hydraulics
    By bigearl42 in forum New Holland Owning/Operating
    Replies: 4
    Last Post: 06-21-2010, 10:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2013 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.