Results 1 to 6 of 6
  1. #1
    New Member
    Join Date
    Jan 2012
    Posts
    6
    Location
    Hilo, Hawaii

    Default JD 1026R starts but idles extremely rough

    My 1026R overheated today-- the grill clogged with fluffy grass seeds, and the automatic PTO shutoff kicked in along with the "engine overheat" message on the LCD display.

    I followed the JD manual instructions, set the throttle to low idle and allowed the engine to cool down before shutting it off. Left the machine off for a couple hours and cleaned the grille and internal screen. Since it was low on fuel, I filled up with fresh diesel.

    Now when I try to start it up, it starts pretty well but then quickly starts to idle extremely rough -- feels like the engine is going to jump out of the machine!

    Any thoughts on what might cause this? I looked at the fuel filter -- looks ok, and the red indicator is not elevated. Checked the oil level-- looks good. Anything else simple I can check?

  2. #2
    Platinum Member
    Join Date
    Jan 2012
    Posts
    933
    Tractor
    2012 John Deere 3520 Deluxe Cab

    Default Re: JD 1026R starts but idles extremely rough

    Quote Originally Posted by tstellanova View Post
    My 1026R overheated today-- the grill clogged with fluffy grass seeds, and the automatic PTO shutoff kicked in along with the "engine overheat" message on the LCD display.

    I followed the JD manual instructions, set the throttle to low idle and allowed the engine to cool down before shutting it off. Left the machine off for a couple hours and cleaned the grille and internal screen. Since it was low on fuel, I filled up with fresh diesel.

    Now when I try to start it up, it starts pretty well but then quickly starts to idle extremely rough -- feels like the engine is going to jump out of the machine!

    Any thoughts on what might cause this? I looked at the fuel filter -- looks ok, and the red indicator is not elevated. Checked the oil level-- looks good. Anything else simple I can check?
    didnt see it mentioned in your post but did you check the air filter as well?

  3. #3
    New Member
    Join Date
    Jan 2012
    Posts
    6
    Location
    Hilo, Hawaii

    Default Re: JD 1026R starts but idles extremely rough

    Yep the air filter is a little grimy but doesn't seem too bad. Also tried starting once with the filter removed...same result.

  4. #4
    Platinum Member
    Join Date
    Mar 2008
    Posts
    599

    Default Re: JD 1026R starts but idles extremely rough

    Outside of calling " 50 " no idea what could be the problem. With so many machines using computers I would not doubt it would have to be reset by a scan tool to restore a program. I am sure the dealer could fill you in on this. Looks like you have checked all the simple solutions. Good luck. New machine should be under warranty so no problem there.

  5. #5

    Default Re: JD 1026R starts but idles extremely rough

    Check and besure that the diesel return line isn't pinched under the foot platform. I know that sounds silly, but at about 220 hrs. my 1026r started doing what you are talking about and that was where the problem was.

  6. #6
    Gold Member Smallplot's Avatar
    Join Date
    Sep 2011
    Posts
    346
    Location
    Pike County Illinois
    Tractor
    1974 IH 1066, 1969 IH 756/FEL, and 2011 TYM T603 Cab/FEL

    Default Re: JD 1026R starts but idles extremely rough

    Something else to check, your fuel system may be sucking in just a little air. Make sure fuel filter is tight and if you have a bleeder valve that it is completely closed. Doesn't take much air bubbling in to make them run rough or to even kill it.
    Dan,
    www.pikecountyfoodplots.com

Similar Threads

  1. Grand L5030 starts/idles perfectly but chokes when loaded.
    By texasjohn in forum Kubota Owning/Operating
    Replies: 28
    Last Post: 04-02-2011, 09:45 PM
  2. 2005 JD 790 Starts and Idles wont Run
    By Bearcreekrockies in forum Owning/Operating
    Replies: 10
    Last Post: 12-03-2010, 09:43 PM
  3. BX 1860 starts rough
    By poldies4 in forum Kubota Owning/Operating
    Replies: 19
    Last Post: 05-14-2010, 09:13 PM
  4. Branson 2910i, starts rough
    By thistlemagnate in forum Century & Branson
    Replies: 22
    Last Post: 01-07-2010, 08:00 PM
  5. Help! BX-23 Barely Running (extremely rough)
    By kwasimoto in forum Kubota Owning/Operating
    Replies: 7
    Last Post: 06-29-2008, 07:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.