Results 1 to 3 of 3
  1. #1
    New Member
    Join Date
    Mar 2009
    Posts
    3

    Default Grinding transmission

    I've got a 2 year old Cub Cadet LT1050 that grinds when I engage the forward or reverse foot lever. It also won't go into neutral when I pull the rod out the back. The park brake doesn't engage either. If I fiddle around with it, sometimes everything works fine. Dealer says $1100 for a new trans! Any ideas?

    Thanks.

  2. #2
    Elite Member George2615's Avatar
    Join Date
    Feb 2005
    Posts
    3,177
    Location
    Central Square, NY
    Tractor
    LS XR3037HC

    Default Re: Grinding transmission

    Don't know about your Cub but at 2 years old isn't it still under warranty?
    I do know on my tractor I have to lube all moving linkages with a penetrant spray every years or they stick / freeze up. Especially the linkage for my differentail lock.

  3. #3
    New Member
    Join Date
    Mar 2009
    Posts
    3

    Default Re: Grinding transmission

    No warranty, I bought it used a few months back. It worked fine until someone was horsing around and drove it into a pile of leaves. I looked underneath, and the only thing I see is a lever for the disengagement. It doesn't look bent or anything, but who knows. Maybe I'll play with that and see what happens.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2013 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.