Results 1 to 2 of 2
  1. #1
    New Member
    Join Date
    Jan 2007

    Default Inland SA-48

    I have an Inland SA-48 (rear mount) on a Kabota B-7100 that has been working great. I started it up this AM and everything seems to be working except as soon as you hit a pile of snow, it bogs down and stops the snowblower but not the tractor. The auger, blades, and PTO are turning fine. Any thoughts? Thanks

  2. #2
    Elite Member
    Join Date
    Jan 2009
    Carroll, Ohio
    IH Farmall 656 gas/ IH 240 Utility/ 2, Super C Farmalls/ 2, Farmall A's/ Farmall BN/McCormick-Deering OS-6/McCormick-Deering O-4/ '36 Farmall F-12/ 480 Case hoe. '65 Ford 2000 3 cyl., 4 spd. w/3 spd Aux. Trans

    Default Re: Inland SA-48

    I found a picture of an SA-60, and there appears to be a slip clutch on the drive line. Maybe yours needs cleaned/adjusted..??

Similar Threads

  1. Financing John Deere 48 Month Financing
    By ayesinstructor in forum John Deere Buying/Pricing
    Replies: 10
    Last Post: 12-16-2009, 11:56 AM
  2. 4300 / 430 FEL / 48 BH
    By Whitey in forum John Deere Owning/Operating
    Replies: 8
    Last Post: 07-20-2009, 09:02 AM
  3. JD 4400 and 48 BH Attachments
    By gewpe in forum John Deere Owning/Operating
    Replies: 4
    Last Post: 05-08-2008, 11:01 PM
  4. Beltec TM 48
    By unreconstructed in forum Attachments
    Replies: 0
    Last Post: 04-30-2008, 01:14 PM
  5. Millonzi 48 grapple/Massey 1533
    By n92687 in forum Attachments
    Replies: 3
    Last Post: 04-15-2008, 10:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
© 2016 TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.