Results 1 to 3 of 3
  1. #1
    Veteran Member
    Join Date
    Jan 2002
    Posts
    1,927
    Location
    Home-1+ acres New Hope, TX / 24 acres-Fannin County
    Tractor
    JD 950

    Default I sprung a leak

    Used my tractor for a while last Wed. Went back Sat. and there was a LARGE puddle of gear lube on the floor under the left front wheel. Looked as if the entire front axle had drained. Apparently a seal completely gave way. [img]/w3tcompact/icons/frown.gif[/img]
    It's a JD 950 MFWD. I haven't had a chance to look thru my service manual yet. Anyone else have any experience replacing seals in a similar application?

  2. #2

    Join Date
    Apr 2002
    Posts
    27
    Location
    Eastern Washington
    Tractor
    Yanmar 2310D

    Default Re: I sprung a leak

    I had a similar experience with a Yanmar. Turned out that the outer flange bolts had worked loose. Both sides! Re-torqued the bolts and on my way. Hasn't so much as seeped since. Maybe you'll luck out like I did. Check it out. Good luck. Darrell

  3. #3
    Veteran Member
    Join Date
    Jan 2002
    Posts
    1,927
    Location
    Home-1+ acres New Hope, TX / 24 acres-Fannin County
    Tractor
    JD 950

    Default Re: I sprung a leak

    The 950 was made by Yanmar. Maybe I will get lucky. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.