Page 1 of 3 123 LastLast
Results 1 to 10 of 24
  1. #1
    Member
    Join Date
    Oct 2009
    Posts
    44
    Tractor
    Kubota L3400HST

    Default L3400 not starting

    Hi guys. I have a 2007 kubota L3400 that will not start. The last few times I noticed a short delay (maybe 1 second) when I turned the key to the start position before the engine rolled over and fired. Now I turn to the start position and nothing. I tested the switch and it works correctly. I spoke with the Kubota service tech and he said there is a starter relay under the dash that could be failing. Anyone have this problem and was it the relay? Further, how difficult is it to access this relay?

    Thanks for your help.
    Kubota L3400HST w/LA463 FEL
    72" finish mower, 60" brush hog, 72" rear blade, 60" box blade, 72" disk, 6-1/2' QA snow plow, 8' drag, post hole digger, QA pallet forks, 15kw pto generator

    RTV500
    Canopy, windshield, brush guard

  2. #2
    teg
    teg is offline
    Elite Member
    Join Date
    Jul 2005
    Posts
    3,954
    Location
    .
    Tractor
    .

    Default Re: L3400 not starting

    So you do not hear any "click" when you turn the key on? Have you tested the battery and looked for corrosion on both ends of the cable, and that the cables are tight. (easy stuff first) Check to make sure hst pedal is in neutral and the PTO is off...

  3. #3
    Member
    Join Date
    Oct 2009
    Posts
    44
    Tractor
    Kubota L3400HST

    Default Re: L3400 not starting

    No click or anything. Battery is good, clutch switch is working correctly, HST pedal is good, PTO position is good. I have ordered a new starter relay. Just wondering what the odds are that this is the problem and if anyone else has had similar issue. Thanks for your help. -33
    Kubota L3400HST w/LA463 FEL
    72" finish mower, 60" brush hog, 72" rear blade, 60" box blade, 72" disk, 6-1/2' QA snow plow, 8' drag, post hole digger, QA pallet forks, 15kw pto generator

    RTV500
    Canopy, windshield, brush guard

  4. #4
    Bronze Member
    Join Date
    Aug 2007
    Posts
    91
    Location
    Kentucky
    Tractor
    L3400

    Default Re: L3400 not starting

    I have had a similar problem with mine. I even went as far as to get the dealer to come to pick it up......Now the rest of the story...or jump to thend for my fix.....The mechanic at the dealership told me to go ahead and cross out the starter with ajumper wire to start it. I did and it started fine. Now the he tells me to leave it running and they will send a truck for it because it is hydrostatic.....(they are at least 40 minutes away).....it gets better. The truck finally shows up and I pull the tractor onto the trailer and shut it down. Then just for giggles tried starting it again......it started at least 20 times with no issues. We decided they couldnt fix it if it wasnt broken so I unloaded off the trailer. A few days later the same thing happened. Crossed the starter no problems for weeks...............All that to say I finally figured out (by accident) that if hydro pedal is just a smidge out of position it will not start. So if yours is the HSD try moving the pedal fore and aft while turning the key. I have had zero problems since

    Hope that works sorry for the long winded story

  5. #5
    teg
    teg is offline
    Elite Member
    Join Date
    Jul 2005
    Posts
    3,954
    Location
    .
    Tractor
    .

    Default Re: L3400 not starting

    With the key in the start position, tap the HST pedal back and forth. See if anything happens.

  6. #6
    Member
    Join Date
    Oct 2009
    Posts
    44
    Tractor
    Kubota L3400HST

    Default Re: L3400 not starting

    Good idea on the HST pedal. I had not played with that switch yet. I will try as soon as I get back to my shop.
    Kubota L3400HST w/LA463 FEL
    72" finish mower, 60" brush hog, 72" rear blade, 60" box blade, 72" disk, 6-1/2' QA snow plow, 8' drag, post hole digger, QA pallet forks, 15kw pto generator

    RTV500
    Canopy, windshield, brush guard

  7. #7
    Member
    Join Date
    Oct 2009
    Posts
    44
    Tractor
    Kubota L3400HST

    Default Re: L3400 not starting

    Guess what, the HST pedal switch was out of adjustment. Looks like another convenient fix using TBN. Thanks guys. -33
    Kubota L3400HST w/LA463 FEL
    72" finish mower, 60" brush hog, 72" rear blade, 60" box blade, 72" disk, 6-1/2' QA snow plow, 8' drag, post hole digger, QA pallet forks, 15kw pto generator

    RTV500
    Canopy, windshield, brush guard

  8. #8
    teg
    teg is offline
    Elite Member
    Join Date
    Jul 2005
    Posts
    3,954
    Location
    .
    Tractor
    .

    Default Re: L3400 not starting

    Quote Originally Posted by jenrow33 View Post
    ..the HST pedal switch was out of adjustment...
    That's good to know and maybe this will help someone else, too. Can you cancel the starter relay order?

  9. #9
    Member
    Join Date
    Oct 2009
    Posts
    44
    Tractor
    Kubota L3400HST

    Default Re: L3400 not starting

    Yes, since my problem happened on a weekend, the part wasn't actually ordered yet. Started her up again today just to make sure everything was good. Tomorrow I'll get some seat time to mow the grass. Pretty sure I'm in the clear now.
    Kubota L3400HST w/LA463 FEL
    72" finish mower, 60" brush hog, 72" rear blade, 60" box blade, 72" disk, 6-1/2' QA snow plow, 8' drag, post hole digger, QA pallet forks, 15kw pto generator

    RTV500
    Canopy, windshield, brush guard

  10. #10
    New Member
    Join Date
    Apr 2012
    Posts
    7
    Location
    middle tn
    Tractor
    kubota L3400 with loader

    Default Re: L3400 not starting

    My L3400 will not turn over. I check all safety switches, removed and cleaned starter, battery post, and ground.
    With the wife turning the key I have voltage at the starter but no voltage at the starter relay singe wire.
    Jumped it over and ran it for 10 mins to blow out the winter. Shut it off and still nothing. Removed dash and cleaned all connections behind it but still nothing.

Page 1 of 3 123 LastLast

Similar Threads

  1. GC2410 Coldest Weather Starting problem
    By MF RED in MT in forum Massey Ferguson Owning/Operating
    Replies: 46
    Last Post: 01-25-2011, 12:14 PM
  2. Backhoe Older John Deere backhoe Hard Starting Question.... Please
    By Dusty1 in forum John Deere Owning/Operating
    Replies: 17
    Last Post: 03-10-2010, 09:57 PM
  3. Grading What are the odds? L3400 front blade sub frame?
    By Harvest Moon in forum Kubota Owning/Operating
    Replies: 0
    Last Post: 02-01-2009, 10:35 AM
  4. L3400 L2800 Position Control Valve Research
    By Harvest Moon in forum Kubota Owning/Operating
    Replies: 0
    Last Post: 12-10-2008, 05:17 PM
  5. L3400 ver L3240
    By Tim Stuart in forum Kubota Buying/Pricing
    Replies: 11
    Last Post: 09-03-2008, 01:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2013 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.