Results 1 to 4 of 4
  1. #1
    New Member
    Join Date
    Aug 2011
    Posts
    4
    Tractor
    JD 790

    Default John Deere 790 Electrical Problem

    Looking for ideas/help. I have a JD 790 - which is a great machine - ~550 hours - very well maintained and has always run great. It worked perfectly on Saturday - went to start it yesterday, and it is totally dead. Not even lights - nothing happens when you turn the key (guages,etc). I am trying to diagnose and fix the problem.

    The battery was old, but still holding charge - nontheless, I replaced it. Cleaned the ground, checked the fuses, all safety switches are in their proper starting position. Chatted with a local used equip dealer and he didn't have any other ideas.

    I'm perplexed - any ideas?

    Thanks for the help.

  2. #2
    Super Member grsthegreat's Avatar
    Join Date
    Jan 2011
    Posts
    6,362
    Location
    north idaho
    Tractor
    dk45se hst cab

    Default Re: John Deere 790 Electrical Problem

    did you check the MAIN fuse located near the starter...its like a 60 amp fuse or so.
    currently own
    2011 Kioti DK45SE HST CAB tractor/loader, Jimna 6" - 3 point wood chipper, 60" JD Brush Hog, JD 60" Rototiller, 3 point post hole digger with hydraulic assist, 3 point spring tooth rake, Fimco 55 gallon weed sprayer with 12 foot boom, 3 point hydraulic wood splitter (home built)
    Quick Attach 79" loader mount snowblower & rear powerpack
    Quick Attach 84" Snow Blade
    Quick Attach 42" pallet forks

  3. #3
    Platinum Member DieselMonk's Avatar
    Join Date
    Dec 2004
    Posts
    583
    Location
    Nova Scotia
    Tractor
    New Holland / T4.75 Powerstar & Boomer 1030, Case 580 SM II

    Default Re: John Deere 790 Electrical Problem

    Some tractors also have a "fuse wire". That one is harder to find and can look o.k. on the outside casing, while the insinde wire is burnt off, thus acting as a fuse.

  4. #4
    New Member
    Join Date
    Aug 2011
    Posts
    4
    Tractor
    JD 790

    Default Re: John Deere 790 Electrical Problem

    Thanks for your help and quick replies. The Main Fuse was fine, but glad to know about that one.

    I found the problem to be the Ground CABLE. It looked fine, but surprisingly was corroded inside the casing - never seen that. I replaced the cable and am up and running.

Similar Threads

  1. John Deere LX279 Drive Train problem
    By Lumpulus in forum John Deere Lawn & Garden
    Replies: 19
    Last Post: 07-13-2013, 07:40 PM
  2. Front-End Loader 27hp John Deere 790 4wd
    By 790greene in forum Attachments
    Replies: 14
    Last Post: 04-11-2012, 10:09 AM
  3. Deere 42'' edge mower deck PA
    By forgeblast in forum Private Party Ads
    Replies: 3
    Last Post: 03-28-2012, 09:59 PM
  4. John Deere compact utility tractor problem.
    By Mcintyre Farms in forum John Deere Owning/Operating
    Replies: 4
    Last Post: 12-13-2010, 08:46 PM
  5. John Deere Ag Website-New
    By Anonymous Poster in forum John Deere Buying/Pricing
    Replies: 1
    Last Post: 05-10-2001, 10:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2013 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.