Results 1 to 7 of 7
  1. #1
    New Member
    Join Date
    Mar 2012
    Posts
    16
    Location
    Markusminde, Denmark
    Tractor
    Ford 4000

    Default Fuel pump

    Hi,

    My Ford 4000 runs fine, but a couple of times in the last weeks it suddenly stops... When I try to start again nothing happens - the motor turns but it dosen't fire. Because there's no smoke at all I think it dosen't get any fuel. So I try to bleed the fule pump and it starts and runs fine again!
    I can't find the reason - it is strange because it just happens now and again - mostly it runs fine. Any suggestions?

  2. #2
    Veteran Member banjodunn's Avatar
    Join Date
    Jun 2008
    Posts
    1,229
    Location
    Oz

    Default Re: Fuel pump

    G'day sound like you might have a blocked filter to me and making the pump suck air, check all your fuel lines from the tank to the inj pump for cracks/looseness



    Jon

  3. #3
    New Member
    Join Date
    Mar 2012
    Posts
    16
    Location
    Markusminde, Denmark
    Tractor
    Ford 4000

    Default Re: Fuel pump

    Hmm... Just thinking it's strange it's not consistently... I'll add a new fuel filter and take a look at the lines...

  4. #4
    Veteran Member banjodunn's Avatar
    Join Date
    Jun 2008
    Posts
    1,229
    Location
    Oz

    Default Re: Fuel pump

    G'day you could also check the fuel tap where it fits into the tank the small strainer screen may be blocked



    Jon

  5. #5
    New Member
    Join Date
    Mar 2012
    Posts
    16
    Location
    Markusminde, Denmark
    Tractor
    Ford 4000

    Default Re: Fuel pump

    Thanks! I'll take that in to account too...

  6. #6
    New Member
    Join Date
    Apr 2012
    Posts
    4
    Location
    grand rapids mi
    Tractor
    case 210 gt

    Default Re: Fuel pump

    Ran into a problem like that with a yard sweeper and found that it was a simple fix crap in the tank plugging the outlet then swish the gas and the thing would run fine for a bit. So I agree with jon

  7. #7
    Platinum Member
    Join Date
    Jan 2009
    Posts
    985
    Location
    upstate South Carolina, Greenville
    Tractor
    Kubota M6800, Massey Ferguson 240

    Default Re: Fuel pump

    My kubota is doing exacty the same thing. I plan to drop the tanks and check the lines and flush the tanks. Hope that will help.

Similar Threads

  1. 425 A Taskmaster (DongFeng ?) with Y385 engine
    By Gramps in NM in forum Chinese Tractors
    Replies: 12
    Last Post: 07-15-2011, 12:36 PM
  2. Oil & Fuel L4400 WATER IN FUEL AND INJECTION PUMP
    By Johnny Burke in forum Kubota Owning/Operating
    Replies: 17
    Last Post: 01-27-2011, 12:17 PM
  3. Bad fuel aftermath
    By farmgirlky in forum Kubota Owning/Operating
    Replies: 31
    Last Post: 08-23-2010, 09:40 PM
  4. Oil & Fuel Fuel problems (algae)
    By rxk9394 in forum Kubota Owning/Operating
    Replies: 13
    Last Post: 01-08-2010, 05:36 PM
  5. JD GX345 Fuel Pump
    By dmorris142 in forum John Deere Lawn & Garden
    Replies: 0
    Last Post: 08-24-2009, 10:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.