Results 1 to 2 of 2
  1. #1
    New Member
    Join Date
    Oct 2012
    Posts
    10
    Location
    Niagara Falls
    Tractor
    755

    Default JD 755 Fuel problems no start

    We have a JD 755 older 1986 yanmar 24000 hrs, yesterday when using tractor tried to re start engine & no start, lots of black smoke, the smoke cleard up when trying to start, have fuel to injection pump no fuel from high side of pump, removed the three injector lines from the pump cranked engine no fuel from injection unit, is there anything I am over looking, fuel shutoff solenoid is operating when I switch the ignition key.
    if anyone could help!
    Thank You

  2. #2
    New Member
    Join Date
    Oct 2012
    Posts
    10
    Location
    Niagara Falls
    Tractor
    755

    Default Re: JD 755 Fuel problems no start

    Quote Originally Posted by hotrodstones View Post
    We have a JD 755 older 1986 yanmar 24000 hrs, yesterday when using tractor tried to re start engine & no start, lots of black smoke, the smoke cleard up when trying to start, have fuel to injection pump no fuel from high side of pump, removed the three injector lines from the pump cranked engine no fuel from injection unit, is there anything I am over looking, fuel shutoff solenoid is operating when I switch the ignition key.
    if anyone could help!
    Thank You
    Well today went to start the engine & it ran fine for about an hour, tonight went to put the tractor away and no power tons of black smoke (to much fuel) and stalls @ Idle thinking the injection pump is done! any sugestions would be great.
    Thank you
    Chris

Similar Threads

  1. Fuel - no start problems
    By powerscol in forum Bobcat Tractors
    Replies: 12
    Last Post: 04-02-2012, 04:49 PM
  2. JD 755 no start problem solved.
    By 65specialk in forum Owning/Operating
    Replies: 4
    Last Post: 02-06-2012, 06:09 PM
  3. JD 755 won't start
    By drcaseyd in forum John Deere Owning/Operating
    Replies: 9
    Last Post: 05-17-2010, 04:29 PM
  4. 755 hard to start, won't idle
    By nightskyisme in forum John Deere Owning/Operating
    Replies: 23
    Last Post: 09-08-2009, 05:16 PM
  5. 755 No start, no electrics
    By Snowman9000 in forum John Deere Owning/Operating
    Replies: 11
    Last Post: 07-14-2009, 12:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2013 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.