Results 1 to 4 of 4
  1. #1

    Default Hydraulic Problem on Kubota M4900

    Had a leak in one of the 3 hoses connecting to my LA1002 FEL, so I replaced all three with new hoses. Now the bucket raises, lowers, and tilts down, but will not tilt up. Also the 3 point hitch will not raise. It was working perfectly before the replacement. Thought I reversed the position of the two hoses connecting to the bucket controller valve so I switched positions and that did not work. Got any ideas? Right now I have the main hose coming from the back of the tractor near the PTO attached to the connector on the face of the controller and the two hoses from underneath the tractor (just above the oil filters) attached to the joy stick controller valves.

  2. #2

    Default Re: Hydraulic Problem on Kubota M4900

    Thanks to the kubota online schematics, I was able to determine the problem. I had the hoses attached incorrectly. Now, if I can only figure out why my joy stick controller continues to leak after having put a new seal kit in it?

  3. #3
    Super Star Member J_J's Avatar
    Join Date
    Sep 2003
    Posts
    16,647
    Location
    JACKSONVILLE, FL
    Tractor
    Power-Trac 1445, KUBOTA B-9200HST

    Default Re: Hydraulic Problem on Kubota M4900

    Sometimes a seal kit is nothing but a band-aid. A worn valve usually needs to be replaced, as the spools are a precision fit, and they don't make replacement spools for valves. When they are worn, they are worn , and it is up to you as to whether you can accept a certain drip rate.

    Low end valves don't even have a seal kit for the spools.
    J.J.

    When I works, I works hard. When I sits and thinks, I goes to sleep.

    Git er done.

  4. #4

    Default Re: Hydraulic Problem on Kubota M4900

    You maybe be correct. Thanks for the suggestion.

Similar Threads

  1. M4900 / LA1002 Hydraulic Problem
    By podzie in forum Kubota Owning/Operating
    Replies: 3
    Last Post: 05-09-2014, 08:37 AM
  2. Kubota M4900 and Hydraulic Lift Disc
    By LeadPoison in forum Attachments
    Replies: 2
    Last Post: 08-08-2010, 10:31 AM
  3. M4900 PTO PROBLEM
    By BBURG14780@AOL.COM in forum Kubota Owning/Operating
    Replies: 1
    Last Post: 05-24-2009, 10:57 AM
  4. M4900 Electrical Problem
    By docmx in forum Kubota Owning/Operating
    Replies: 12
    Last Post: 11-04-2008, 09:06 AM
  5. Alternator Problem on M4900
    By docmx in forum Kubota Owning/Operating
    Replies: 12
    Last Post: 07-14-2008, 11:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.