Results 1 to 5 of 5
  1. #1
    Bronze Member
    Join Date
    Sep 2012
    Posts
    81
    Location
    Southwick,MA
    Tractor
    Pasquali 993 w/FEL, Economy2414 w/FEL

    Default Charging Issue

    I've got a Pasquali 993 with the 30hp Ruggerini 2cyl, it uses old-school alternator with separate voltage regulator. Noticed after installing some aux. lights, that it was not charging the battery. Put load-meter on it, & at 2500rpm had 13.3vdc & 4.3 amp-output, at max rpm of 3000 had only 13.7vdc @ 5 amps. Saw in an old PDF manual that it should be 14.8vdc & 18 amp output @ 3000rpm. But the manual is very-vague as to whether to go after the voltage-regulator or the stator-windings/de-magged rotor.
    I ohmmed out the 3 wires coming out the stator (2 yellows & red), got continuty between 1 yellow & red. Manual shows 2 yellows tied together when checking for open-circuit across the red, but that doesn't make sense to me. Their is no continuty between the 2 yellows themselves, & nothing for all 3 to ground. Figured I might try & use the voltage regulator off my '64 Springfield GT50, it used a very simular set up (combo starter/generator & voltage regulator @ 15amps). Gotta be cheaper than any virtually-extinct OEM part.
    Thanks Guys!

    Shadow
    Growing older is... MANDATORY, Growing up is... OPTIONAL

  2. #2
    Gold Member
    Join Date
    Jan 2006
    Posts
    347
    Location
    Stone Mountain, GA
    Tractor
    Case 1210, Mitsubishi D2050

    Default Re: Charging Issue

    It's not nearly as common for those "dynamos" to fail, as it is for the diodes and regulator. From what you are saying it sounds like everything but the windings are external to the unit itself, so I would focus on checking out the diodes first. There are typically 3-8 of them, and it sounds like the majority of them are blown out. A simple ohmmeter check of them should show continuity in one direction and high resistance in the other direction.

    Good luck!

  3. #3
    Gold Member
    Join Date
    May 2011
    Posts
    359
    Location
    NKY
    Tractor
    Yanmar YM186d,John Deere 1050, Case 211B

    Default Re: Charging Issue

    Is the stator under the flywheel,like a lawnmower? Or does it have an automotive type alternator? If it is under the flywheel,then unplug it,start it up,and check the output-should be AC voltage.
    JD1050,YM186D,Case211B,Homemade- sawmill & log splitter & log hauling arch trailer
    JD14T,Ford 532 balers,
    AC 80-R3,Ford 501 sickle mowers
    2.1 KW Off-grid Solar System and growing

  4. #4
    Bronze Member
    Join Date
    Sep 2012
    Posts
    81
    Location
    Southwick,MA
    Tractor
    Pasquali 993 w/FEL, Economy2414 w/FEL

    Default Re: Charging Issue

    It's the buried under 40 lbs of stuff, type, but if I find the stator is toasted, it will be getting an AC Delco SI 35amp upgrade! Parts are hard to comeby for these Pasquali's, so upgrades are almost a requirement.
    I will check the AC output coming out of the stator tonight, should I have AC on all 3 legs coming out of the stator or just 2?
    Had my voltmeter & loadmeter on it this morning in the dark, clearing out the heavy-wet, 10" of "white-stuff," while only running 1 back-up light & 2 running lights. Had rpm at 2000, with 12.7v and 2.3amp output, not great but at least not drawing the battery below 12vdc.
    Thanks again,
    Shadow
    Growing older is... MANDATORY, Growing up is... OPTIONAL

  5. #5
    Bronze Member
    Join Date
    Sep 2012
    Posts
    81
    Location
    Southwick,MA
    Tractor
    Pasquali 993 w/FEL, Economy2414 w/FEL

    Default Re: Charging Issue

    Ok, disconnected the 2 yellows & red coming out of the stator. Have 40vac on one yellow & red (common), & nothing on the other yellow to red. I think the stator windings are shot or their is an open circuit somewhere in it.

    Shadow
    Growing older is... MANDATORY, Growing up is... OPTIONAL

Similar Threads

  1. Charging issue
    By MACHZM10 in forum Toolcat
    Replies: 8
    Last Post: 04-29-2012, 03:26 PM
  2. SCAG wildcat charging issue????????
    By LD1 in forum General Lawn & Garden
    Replies: 5
    Last Post: 06-05-2011, 02:07 PM
  3. ts1910 charging issue
    By abee6743 in forum Iseki
    Replies: 1
    Last Post: 12-13-2010, 08:15 PM
  4. jd 316 charging issue revisited
    By farmerjim in forum John Deere Lawn & Garden
    Replies: 0
    Last Post: 10-12-2010, 09:24 PM
  5. '03 Simplicity Conquest 1844 Charging Issue?
    By shortlid in forum Simplicity
    Replies: 1
    Last Post: 10-09-2007, 08:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.