Results 1 to 9 of 9
  1. #1
    New Member
    Join Date
    Mar 2013
    Posts
    4
    Location
    Oakland, OR
    Tractor
    John Deere 4600

    Default JD 4600 electrical problem

    Will not turn over. Batterie good (12.49 v). Starter fuse good. Pulled the starter/selinoid, they both worked perfect with jumper cables to the battery. When i turn the starter switch on sometimes it won't even light up the icons on dash. When it does and i turn it to start i hear a click and ever thing goes blank (dash lights). I've bypast the nutral switch, seat switch, shuttel lever in neutral, foot on clutch etc. Not sure how to check if the relay is good, but switched the starter relay with a couple of others and still nothing. Tried to bypast the starter switch, jumping from the positive terminal on starter to the leed on selinoid as i did when testing removed but all i got was an initial click of selinoid then nothing! How can this be? Thanks

  2. #2
    Elite Member Don87's Avatar
    Join Date
    May 2010
    Posts
    4,226
    Location
    SW Pa.
    Tractor
    Massey Ferguson GC2400

    Default Re: JD 4600 electrical problem

    Bad hot or ground on the tractor?
    Don

    MF GC2400, FEL, 60in.MMM, 5ft. Cultivator, Single Bottom Plow, Bush Hog RTC48 tiller, MF 2360 front mount snowblower, 5ft backblade. BXpanded Piranha toothbar.

  3. #3
    Veteran Member
    Join Date
    May 2008
    Posts
    1,275
    Location
    Eastern Ia
    Tractor
    JD 4310 eHydro,

    Default Re: JD 4600 electrical problem

    Take the battery out and have it load tested. My guess is it is bad. Had the same thing on my motorcycle this summer. Had 12.4 on volt meter and showed the same with starter button depressed. Load test showed 126 amp.......needed 450.

  4. #4
    Elite Member Don87's Avatar
    Join Date
    May 2010
    Posts
    4,226
    Location
    SW Pa.
    Tractor
    Massey Ferguson GC2400

    Default Re: JD 4600 electrical problem

    Quote Originally Posted by mfreund View Post
    Take the battery out and have it load tested. My guess is it is bad. Had the same thing on my motorcycle this summer. Had 12.4 on volt meter and showed the same with starter button depressed. Load test showed 126 amp.......needed 450.
    That was my first thought, but the OP said he hooked jumpers to the tractor battery and the starter worked fine.

    But after reading his post again.......I see the starter was off the tractor doing that test(thus no load on starter). You could be right.
    Don

    MF GC2400, FEL, 60in.MMM, 5ft. Cultivator, Single Bottom Plow, Bush Hog RTC48 tiller, MF 2360 front mount snowblower, 5ft backblade. BXpanded Piranha toothbar.

  5. #5
    New Member
    Join Date
    Mar 2013
    Posts
    4
    Location
    Oakland, OR
    Tractor
    John Deere 4600

    Default Re: JD 4600 electrical problem

    Quote Originally Posted by Don87 View Post
    That was my first thought, but the OP said he hooked jumpers to the tractor battery and the starter worked fine.

    But after reading his post again.......I see the starter was off the tractor doing that test(thus no load on starter). You could be right.
    I will pull the battery and have it load tested, also double check the ground.
    Thanks for your help.

  6. #6
    Elite Member Don87's Avatar
    Join Date
    May 2010
    Posts
    4,226
    Location
    SW Pa.
    Tractor
    Massey Ferguson GC2400

    Default Re: JD 4600 electrical problem

    Quote Originally Posted by Ron Robinson View Post
    I will pull the battery and have it load tested, also double check the ground.
    Thanks for your help.
    Let us know what you find. And welcome to TBN.
    Don

    MF GC2400, FEL, 60in.MMM, 5ft. Cultivator, Single Bottom Plow, Bush Hog RTC48 tiller, MF 2360 front mount snowblower, 5ft backblade. BXpanded Piranha toothbar.

  7. #7
    New Member
    Join Date
    Mar 2013
    Posts
    4
    Location
    Oakland, OR
    Tractor
    John Deere 4600

    Default Re: JD 4600 electrical problem

    Found it!! Thought I'd already checked, but the positive cable had a loose connection to the cable end that connects to the battery. That was too easy, i like it!

    Thanks for all your help!

  8. #8
    Veteran Member
    Join Date
    May 2008
    Posts
    1,275
    Location
    Eastern Ia
    Tractor
    JD 4310 eHydro,

    Default Re: JD 4600 electrical problem

    When the battery went bad I hooked the lawn mower to it to jump it, it would not go. Glad you found it and it was easy!!

  9. #9
    New Member
    Join Date
    Apr 2013
    Posts
    1
    Location
    Evans Mills, NY
    Tractor
    John Deere 4600

    Default Re: JD 4600 electrical problem

    About a year ago had a similar problem where starter would only click. Used the 110 amp booster to start the the tractor. After the second time I decided to change the battery which was at least 8 years old. All was well until about two weeks ago. We had little snow this year and the tractor hadn't been started in several weeks. After reading the above posts I purchased new battery cables from my JD dealer. I found the ground cable to be very corroded where it attaches to the engine block. After replacing the cleaning connections and replacing cables the problem was still present. I changed the cables in near darkness in my garage and initially failed to notice that there is a nut under the point where the positive cable attaches to the solenoid and it had come loose. This was spotted by my son-in-law when he was helping me retrace my steps. As soon as it was tightened the engine cranked after reattaching the battery cable. Moral of story, get your drop light out and keep your eyes open the first time.

Similar Threads

  1. JD 4600 hydraulics problem
    By jimfitz in forum Hydraulics
    Replies: 6
    Last Post: 10-02-2012, 07:40 PM
  2. ford 4600 lift arm problem
    By treesrus1 in forum Hydraulics
    Replies: 3
    Last Post: 06-02-2012, 09:57 PM
  3. JD 4600 mfwd front axle problem
    By sqdqo in forum John Deere Owning/Operating
    Replies: 0
    Last Post: 07-10-2011, 04:15 PM
  4. John Deere 4600 fuel guage problem
    By pendog in forum Parts/Repairs
    Replies: 5
    Last Post: 07-14-2009, 02:18 AM
  5. JD 4600 HST PTO Problem
    By kabeman in forum John Deere Owning/Operating
    Replies: 16
    Last Post: 07-22-2008, 01:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.