Results 1 to 1 of 1
  1. #1
    New Member
    Join Date
    May 2013
    Posts
    14
    Location
    Savannah, MO
    Tractor
    New Holland TC 40 DA

    Default TC 40 DA Blowing Fuse

    My New Holland TC 40 DA has started blowing the 7.5 amp number five fuse. This takes out my high gear range and cruise control. The tractor starts fine and will run 15-30 mins. before the fuse blows. I have looked for a frayed wire but haven't found any. I have switched the relays and that hasn't helped. Can the diode be bad? I will appreciate anybody's suggestions. This is getting very frustrating. Up until now the tractor/cab had been fine.
    Last edited by dakota52; 05-14-2013 at 11:48 PM.

Similar Threads

  1. blowing fuse #5
    By Lone Oak Landscaping in forum New Holland Owning/Operating
    Replies: 8
    Last Post: 06-08-2009, 11:38 PM
  2. Keep blowing a fuse
    By aemiller4 in forum John Deere Owning/Operating
    Replies: 4
    Last Post: 04-26-2009, 08:07 PM
  3. TC-33 Blowing the #2 Fuse
    By tkcomer in forum New Holland Owning/Operating
    Replies: 34
    Last Post: 08-05-2006, 01:15 PM
  4. 30 Amp fuse keeps blowing
    By SevenCorners in forum Chinese Tractors
    Replies: 37
    Last Post: 11-30-2004, 07:24 PM
  5. Fuse keeps Blowing!!!!
    By ohiocub in forum Parts/Repairs
    Replies: 6
    Last Post: 08-26-2004, 01:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2016 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.