Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    Silver Member hernando's Avatar
    Join Date
    Nov 2003
    Posts
    225
    Location
    tennessee
    Tractor
    1540 massey ferguson

    Default pto trouble

    on a massey ferguson 1540 the pto has a switch on the dash that turns it on and off.i think most compacts are this way. I was bushhoging in some thick blackberrys yesterday and the pto just stoped working....the switch was still on..so I turned it off and back on a few times...after a few min. it started working again,,,this went on all day but only in tall grass..could my pto clutch be slipping ? or could my dash switch be going out ? the switch has started to stick at times...just not sure what to check ...help me if you can thanks bruce and sorry for the long post..
    Bruce neal

  2. #2
    Silver Member hernando's Avatar
    Join Date
    Nov 2003
    Posts
    225
    Location
    tennessee
    Tractor
    1540 massey ferguson

    Default Re: pto trouble

    anyone ? have any idea ???
    Bruce neal

  3. #3
    Elite Member Don87's Avatar
    Join Date
    May 2010
    Posts
    4,226
    Location
    SW Pa.
    Tractor
    Massey Ferguson GC2400

    Default Re: pto trouble

    If the switch has started to stick at times, I would start there.

    You can use a test light to check for power and ground. Work the switch several times during the process and watch for changes.

    Or check the switch when you know it's working, and then check again when the PTO quits.

    If the tractor sits outside, water could have gotten into the switch and corroded it, or the plug itself could be corroded, causing loss of contact.
    Don

    MF GC2400, FEL, 60in.MMM, 5ft. Cultivator, Single Bottom Plow, Bush Hog RTC48 tiller, MF 2360 front mount snowblower, 5ft backblade. BXpanded Piranha toothbar.

  4. #4
    Super Star Member RoyJackson's Avatar
    Join Date
    Nov 2001
    Posts
    18,045
    Location
    Bethel, Vermont
    Tractor
    John Deere 4400 MFWD, Deere 855D UTV and assorted implements

    Default Re: pto trouble

    Look for any wiring that may have pulled loose. Going through any type of brush can snag things...wiring is just one of them.
    Roy Jackson

    "Any government that does not trust its citizens with firearms is either a tyranny, or planning to become one."
    -Joseph P. Martino

  5. #5
    Silver Member hernando's Avatar
    Join Date
    Nov 2003
    Posts
    225
    Location
    tennessee
    Tractor
    1540 massey ferguson

    Default Re: pto trouble

    thanks for the help that gives me a place to start,,,,,bruce
    Bruce neal

  6. #6
    Super Member JerryG's Avatar
    Join Date
    Apr 2000
    Posts
    7,171
    Location
    Northwest Arkansas
    Tractor
    MF 1440-4 PowerShuttle

    Default Re: pto trouble

    Bruce, that is about how mine was. Replaced it and no more problems.

  7. #7
    Silver Member hernando's Avatar
    Join Date
    Nov 2003
    Posts
    225
    Location
    tennessee
    Tractor
    1540 massey ferguson

    Default Re: pto trouble

    thanks jerry...going to try that first....
    Bruce neal

  8. #8
    Silver Member hernando's Avatar
    Join Date
    Nov 2003
    Posts
    225
    Location
    tennessee
    Tractor
    1540 massey ferguson

    Default Re: pto trouble

    jerry you were right,,i changed out the switch,,,and all is well...thanks again for the help .........bruce
    Bruce neal

  9. #9
    Silver Member hernando's Avatar
    Join Date
    Nov 2003
    Posts
    225
    Location
    tennessee
    Tractor
    1540 massey ferguson

    Default Re: pto trouble

    new trouble...it started the same thing all over again,,,,,,has anyone ever changed the pto clutch before ?? I hope it dont come to that going to do some wire checking first....thanks for anymore help yall can give.....bruce
    Bruce neal

  10. #10
    Bronze Member
    Join Date
    Jul 2013
    Posts
    73
    Location
    nz
    Tractor
    MF5465

    Default Re: pto trouble

    Hello, have you checked the sensor on the pto? My 6910 would cut out like yours on pto work and the pto sensor had gone faulty, while the switch was good.
    Last edited by redman135; 07-27-2013 at 08:46 AM. Reason: changed wording

Page 1 of 2 12 LastLast

Similar Threads

  1. LA140 w/intermittent PTO, melted PTO Clutch Switch and blown 20A fuse
    By Juan Deere in forum John Deere Lawn & Garden
    Replies: 8
    Last Post: 06-26-2013, 04:23 PM
  2. Why are attachments sold with half a PTO, or no PTO.
    By CliffordK in forum Attachments
    Replies: 10
    Last Post: 06-23-2013, 09:08 AM
  3. PTO LIGHT WON'T GO OFF
    By L7864S1247 in forum Parts/Repairs
    Replies: 0
    Last Post: 06-21-2013, 08:07 AM
  4. Replies: 4
    Last Post: 05-31-2013, 06:41 PM
  5. 7710 fuel gauge trouble (need help trouble shooting problem)
    By pharmvet in forum New Holland Owning/Operating
    Replies: 6
    Last Post: 01-27-2011, 02:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2013 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.