Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Veteran Member
    Join Date
    Jan 2002
    Posts
    1,561
    Location
    South East Michigan
    Tractor
    New Holland TC30 Hydro 4x4, Gravely Zero Turn Mower

    Default What is wrong with my Pressure Washer pump ?

    My Pressure Washer is capable of 3000 psi at 3gpm. After four years of homeowner use, it has begun to behave poorly. When I start the machine, the pump only produces about 500 psi. The engine runs strong but is clearly not under load. After about 5 minutes of operation, the pump will suddenly kick up to full power (about 2800 psi). Here is a picture of the Comet pump with one cap removed.
    Attached Images Attached Images

  2. #2
    Veteran Member
    Join Date
    Jan 2002
    Posts
    1,561
    Location
    South East Michigan
    Tractor
    New Holland TC30 Hydro 4x4, Gravely Zero Turn Mower

    Default Re: What is wrong with my Pressure Washer pump ?

    There are six valves of some sort on the unit. I removed and inspected each one. They all operate and seem free of minerals. See pic.
    Attached Images Attached Images

  3. #3
    Veteran Member
    Join Date
    Jan 2002
    Posts
    1,561
    Location
    South East Michigan
    Tractor
    New Holland TC30 Hydro 4x4, Gravely Zero Turn Mower

    Default Re: What is wrong with my Pressure Washer pump ?

    Ok, what do I do next ?

  4. #4
    Platinum Member
    Join Date
    Apr 2002
    Posts
    795
    Location
    New England...Central MA
    Tractor
    TC35D/16LA

    Default Re: What is wrong with my Pressure Washer pump ?

    Could it be as simple as air in the system and preventing the pump from moving fluid ??

    I'd look at your suction side to see if maybe a hose is cracked or a fitting is messed-up.

    Don't know much about pressure washers 'cept they don't make good air compressers [img]/forums/images/graemlins/grin.gif[/img].

  5. #5
    Platinum Member GregJ's Avatar
    Join Date
    Oct 2002
    Posts
    703
    Location
    Washington
    Tractor
    Kubota B7500/LA302FEL/4672BH ; John Deere LX277

    Default Re: What is wrong with my Pressure Washer pump ?

    Sounds like a sticking unloader valve (pressure relief valve). I had the exact opposite problem with mine. It would not release pressure when not pumping water. I took it apart, cleaned it up and it's worked fine ever since.

    Hope this helps,

    Greg

  6. #6
    Super Member
    Join Date
    Oct 2003
    Posts
    7,345
    Location
    Northeast, Ohio
    Tractor
    TC-40D SS New Holland

    Default Re: What is wrong with my Pressure Washer pump ?

    Jerry I would agree with Greg and first suspect the pressure relief. Yours looks similar to the one installed on my machine and appears to be adjustable (large black knob in picture). Have you tried completely backing it off while running, turning it counterclockwise and then readjusting it turning it clockwise to see if that might clear any sediment and get it up to operating pressure.

    The op book that came with my pressure washer also lists a worn seal or packing, worn or obstructed valves, or a worn unloader piston as possible causes. I hope some of this info helps you.

  7. #7
    Veteran Member
    Join Date
    Jan 2002
    Posts
    1,561
    Location
    South East Michigan
    Tractor
    New Holland TC30 Hydro 4x4, Gravely Zero Turn Mower

    Default Re: What is wrong with my Pressure Washer pump ?

    Thanks for the tip. I'll take a look at the unloader valve.

  8. #8
    Veteran Member
    Join Date
    Jan 2002
    Posts
    1,561
    Location
    South East Michigan
    Tractor
    New Holland TC30 Hydro 4x4, Gravely Zero Turn Mower

    Default Re: What is wrong with my Pressure Washer pump ?

    Update:

    I ran the unloader valve all the way in and then back out. I'm pretty sure the unloader is the problem as it works much better now. I used the pwasher today and it only acted-up once and I could see the spring on the unloader valve pop up when it kicked back on. Next step will be to remove the valve and give a good cleaning and polish of the surfaces. Thanks again.

  9. #9
    Veteran Member
    Join Date
    Jan 2002
    Posts
    1,561
    Location
    South East Michigan
    Tractor
    New Holland TC30 Hydro 4x4, Gravely Zero Turn Mower

    Default Re: What is wrong with my Pressure Washer pump ?

    Also, in my first photo, you can see a brass cap to the right of the unloader valve. This cap has vent holes in it. Water drips out of this vent even with the engine turned off and no pressure in the system (other than the 50psi from the garden hose input)

  10. #10
    Veteran Member
    Join Date
    Jul 2003
    Posts
    2,088

    Default Re: What is wrong with my Pressure Washer pump ?

    Mine is about the same size as yours (3500# at 4 gpm), and the pump looks similar. We used it nearly every day in the buisiness to clean grills, and didn't have time to mess with it. About once a year it had symptoms like yours and we would just run it down the block to the sprayer company, who would give us a loaner while they fixed the unloader valve and serviced the machine. It was always the unloader.

    The business is closed but I still have the washer. I don't use it as much since then, and it's been fine for the last couple of years.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.