Results 1 to 8 of 8
  1. #1
    New Member
    Join Date
    Sep 2015
    Posts
    23
    Location
    Guntersville,AL
    Tractor
    Yanmar YM3000 Kubota L3430HSTC

    Default YM3000 injector pump linkage/engine run away

    My throttle on my YM300 has become inoperable and the tractor only runs wide open in a run away state. I have taken the throttle linkage loose from the lever on the injector pump and there is spring tension on the lever from inside the crank case but it does nothing to control engine speed. This evening I'm going to remove the inspection plate and see if I can determine what has come loose. What should I be looking for in there and can I resolve this problem thru that opening with the plate off?

  2. #2
    Super Member Coyote machine's Avatar
    Join Date
    May 2009
    Posts
    6,388
    Location
    Southern VT
    Tractor
    '10 Kioti DK 40se/hst KL-401 FEL, loaded tires, KB-2485 bhoe, Tuffline TB160 boxblade, Woods QA forks, MIE Hydraulic bhoe thumb & ripper tooth, Igland 4001 winch, & GR-20 Log Grapple. Woods BBX72" Mower. Diamondplate aluminum canopy.

    Default Re: YM3000 injector pump linkage/engine run away

    First, Welcome to TBN. Sorry for your situation too. It sounds like your IP rack, (internal to the pump) is stuck wide open. I'm not familiar with your specific tractor, nor it's IP. I suggest you call Conestoga Diesel in PA, to ask them what to do and how. They have provided services for Kioti owners here at TBN, and are familiar with all kinds of IPs and tractors.
    I wouldn't start the tractor until you can get the pump to run it at normal speed. This may entail pump removal and repair, which will be less expensive than rebuilding a blown engine.
    2010 DK-40se/hst, KL-401 FEL, (reversible cutting edge), Titan Tree Shear. 72" Ratchet Rake. Fit Rite Top-N-Tilt hydraulics & diverter. HLA Series 2000 7' plow, Aquiline MPC rear chains. Samuri Sickle bar.

    2015 Husky AWD Rider 322T Combi 103 deck. Scag Wildcat: Kawasaki 26HP, bagger. Dr. brush mower, & 42" lawn deck, Dr. self propelled, 6.5HP Trimmer mower. Pro-Mow 3 gang, no HP.

    Bunch of STIHL chainsaws: 011x 2, MS192T, MS200T, MS180C, MS230, MS270 (Wood Boss), 038 Farmboss.

  3. #3
    New Member
    Join Date
    Sep 2015
    Posts
    23
    Location
    Guntersville,AL
    Tractor
    Yanmar YM3000 Kubota L3430HSTC

    Default Re: YM3000 injector pump linkage/engine run away

    Thanks for the welcome. I used to be on here but forgot my un and pw so I just re-registered.

    I was hoping that somebody would respond with a pic or firsthand knowledge of the internal linkage.I'm quite mechanically inclined, have rebuilt engines, have tools, etc but gasoline engines have been my forte.

  4. #4
    Gold Member woolyAcres's Avatar
    Join Date
    Jun 2010
    Posts
    455
    Location
    Western PA
    Tractor
    YM240D

    Default Re: YM3000 injector pump linkage/engine run away

    Hi WileyG-

    You might get a few answers by posting in the Yanmar specific (Yanmar OLD) forum. I know there are some folks there that know these machines inside and out.

    Sorry I don't have anything better to offer.

  5. #5
    Super Member Coyote machine's Avatar
    Join Date
    May 2009
    Posts
    6,388
    Location
    Southern VT
    Tractor
    '10 Kioti DK 40se/hst KL-401 FEL, loaded tires, KB-2485 bhoe, Tuffline TB160 boxblade, Woods QA forks, MIE Hydraulic bhoe thumb & ripper tooth, Igland 4001 winch, & GR-20 Log Grapple. Woods BBX72" Mower. Diamondplate aluminum canopy.

    Default Re: YM3000 injector pump linkage/engine run away

    Here's what I'd do. Remove the inspection plate with the tractor off. See if you can access the rack visually or physically, or both. Take pics, post them, and wait for replies. If it seems possible to move the rack, without doing further damage, you might try doing so, but I doubt you will be able to without further dismantling.
    The old Yanmar forum could be a good place to repost this thread too.
    2010 DK-40se/hst, KL-401 FEL, (reversible cutting edge), Titan Tree Shear. 72" Ratchet Rake. Fit Rite Top-N-Tilt hydraulics & diverter. HLA Series 2000 7' plow, Aquiline MPC rear chains. Samuri Sickle bar.

    2015 Husky AWD Rider 322T Combi 103 deck. Scag Wildcat: Kawasaki 26HP, bagger. Dr. brush mower, & 42" lawn deck, Dr. self propelled, 6.5HP Trimmer mower. Pro-Mow 3 gang, no HP.

    Bunch of STIHL chainsaws: 011x 2, MS192T, MS200T, MS180C, MS230, MS270 (Wood Boss), 038 Farmboss.

  6. #6
    Gold Member
    Join Date
    May 2011
    Posts
    489
    Location
    NKY
    Tractor
    Yanmar YM186d,John Deere 1050, Case 211B

    Default Re: YM3000 injector pump linkage/engine run away

    YM3000 injector pump linkage/engine run away-336-rack-jpg
    This is the "Rack" on the pump. It has a flat lever attached to the pin,with a little bushing and a hair pin. The rack is probably stuck? It should move freely in and out of the pump. Take off the breather cover above the pump and you can see it and maybe free it up.Or you might have linkage problems?Won't know till you look.
    JD1050,YM186D,Case211B,Homemade- sawmill & log splitter & log hauling arch trailer
    JD14T,Ford 532 balers,
    AC 80-R3,Ford 501 sickle mowers
    2.1 KW Off-grid Solar System and growing

  7. #7
    New Member
    Join Date
    Sep 2015
    Posts
    7
    Location
    Bay City
    Tractor
    JD

    Default Re: YM3000 injector pump linkage/engine run away

    Had one doing the same thing, The little hair pin Barry 1 mentioned had fallen off and the engine ran away as soon as the engine started.

  8. #8
    New Member
    Join Date
    Sep 2015
    Posts
    23
    Location
    Guntersville,AL
    Tractor
    Yanmar YM3000 Kubota L3430HSTC

    Default Re: YM3000 injector pump linkage/engine run away

    Thanks for the replies. I ended up having to pull the pump. The gear on the first injector had somehow become disengaged from the rack and stuck the rack. She's now running like she always had before the issue.

Similar Threads

  1. Won't Start or Run Without Injector Pump Bleed
    By Riddler in forum New Holland Owning/Operating
    Replies: 4
    Last Post: 07-22-2015, 10:26 AM
  2. JD 855 - diesel in the engine oil - fuel injector pump?
    By Nick S in forum John Deere Owning/Operating
    Replies: 0
    Last Post: 01-11-2015, 04:17 AM
  3. Injector pump / engine timing
    By firefighterfox in forum Parts/Repairs
    Replies: 7
    Last Post: 03-03-2014, 09:53 AM
  4. What's wrong with my tractor? Engine? Injector Pump?
    By npaden in forum Owning/Operating
    Replies: 34
    Last Post: 06-18-2013, 12:30 AM
  5. Engine size needed to run pump
    By sportnatic in forum Hydraulics
    Replies: 2
    Last Post: 02-04-2011, 12:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2016 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.