Results 1 to 2 of 2
  1. #1

    Join Date
    Sep 2003
    Woodlawn (near Ottawa), Ontario

    Default Did my first 50 hrs maintenance ... oh no..!

    Engine oil/filter went fine.

    Hydraulic oil.. didn't realize that it would gush out the plug and hit the tire wall instead of dripping in the pan. Seeing this, I tried to hold the pan higher but the weight became too much (my arms were extented). So I had a nice 4'x4' oil swamp on the cement floor. Time for the cat litter.

    On the positive side by doing this maintenance, I noticed that the other plug was loose (there's two on each side of the transmission). I could have lost all my oil in the field.

    Question: I have filled the oil to the top mark of the dipstick, started the tractor, let it run and checked for leaks (I exercised the loader/3ph too). Then I turned off the tractor, let it cool down and the oil is at the bottom mark of the dipstick. Is this normal ?

  2. #2
    Veteran Member
    Join Date
    Jun 2003
    Northern, New York
    Kubota L3830 03: RTV 900

    Default Re: Did my first 50 hrs maintenance ... oh no..!

    That would be the norm cause there was probably some air pockets in the system. Add enought oil to get the level half way between the two marks and you should be OK.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
© 2016 TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.