Results 1 to 6 of 6
  1. #1

    Default Argghh!! Engine Quits When I Engage Blades!!

    I just replaced pto clutch because previous owner said it was bad.When I try to engage blades the engine quits.
    Its a Cub Cadet 2140.Any help would be greatly appreciated. [img]/forums/images/graemlins/confused.gif[/img]

  2. #2
    Elite Member Gatorboy's Avatar
    Join Date
    Aug 2001
    Posts
    3,099
    Location
    Bel Air, MD
    Tractor
    Kubota M8950, Bobcat 873 SSL & Kubota ZD-331

    Default Re: Argghh!! Engine Quits When I Engage Blades!!

    Check to make sure all spark plugs are firing. I had a similar problem with my Scag Walk-behind -- one of the cylinders was dead -- it seemed to run fine, but as soon as I engaged the blades, it bogged down and quit.

  3. #3
    Gold Member
    Join Date
    May 2004
    Posts
    457
    Location
    SW of Minneapolis, MN
    Tractor
    2003 Kubota L3430 HSTC

    Default Re: Argghh!! Engine Quits When I Engage Blades!!

    Is your PTO clutch an electric engaged clutch? If so, you must have created a short when you installed the new one.

    OrangeGuy

  4. #4
    Silver Member
    Join Date
    Sep 2001
    Posts
    123
    Location
    Kentucky (in the bluegrass!)
    Tractor
    Kioti LK3054, IH cub cadet 782, Grasshopper 721D2

    Default Re: Argghh!! Engine Quits When I Engage Blades!!

    On my 782 it has a seat switch which will kill the engine if the mower clutch (electric) is engaged and the switch is not depressed. Perhaps your switch is bad.

  5. #5

    Default Re: Argghh!! Engine Quits When I Engage Blades!!

    Thanks For All your Help .It was The seat switch.SO far everythings working fine.Thanks Again. [img]/forums/images/graemlins/grin.gif[/img]

  6. #6

    Default Re: Argghh!! Engine Quits When I Engage Blades!!

    </font><font color="blue" class="small">( Thanks For All your Help .It was The seat switch.SO far everythings working fine.Thanks Again. )</font>
    Hey! This is great. I finally got to this post, and you're problem is already over, and you said what it was that fixed it. Now I'm just waiting to hear how you fixed the other two!!
    [img]/forums/images/graemlins/grin.gif[/img] John

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.